"." problem with domain & ssl error

Discussion in 'Installation/Configuration' started by webcooker, Jul 14, 2018.

  1. webcooker

    webcooker New Member

    Greetings i have follow the perfect server debian 9 stretch which is working perfect in raspberry pi
    my server is server.example.com (FQDN)
    and create a simple html site www,example,com
    and another wordpress site www,example1,com


    when i insert a dot "."" after the domain for example www,example,com, it show me ssl error and the ssl certificate of www,example1,com

    why is happening this

    which htaccess rule i have to write?
    or dns records should i put?
    example,com, or example,com?

    what is the meaning of "." in dns records

    !i change in this post "," for "." just to post!
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    First, you have to differentiate between an email domain, website domain, and dns. Email and website domains never end with a dot. A dot at the end of a domain name is only used in DNS, it defines that this domain is a fully qualified domain name, so the zone name does not get appended. This is not ispconfig specific btw., that's the normal syntax used by e.g. BIND dns server and others.

    Rgarding your SSL error, you can only obtain a letsencrypt ssl cert for a domain you own and this domain must point to your server in dns. If that's not the case, then LE will not issue an SSL cert for this domain and SSL will not get enabled and you will end up at another domain in case you try to reach that domain with https.
     
    webcooker likes this.
  3. webcooker

    webcooker New Member

     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Of course you can reply, you are just not allowed to post any links as a new user.
     
  5. webcooker

    webcooker New Member

    thanks for the answerd i know that is not ispconfig problem.

    i resolve my issue with domain example1.com i just remove "." at the end of hostname from dns records.
    but my domain server,example,com (FQDN) and website at www,example,com not.
    if i insert in url "." for exampe html:/www,example,com. it show me a ssl error and the ssl certificate of example1,com how to resolve this? my /etc/hosts is localip server,example,com server
    with my own domain nameservers ns1,example,com and ns2,example.com

    i change ''," to "." and https to html in order to reply back :)
     

Share This Page