Problem with DNS, suse 13.1

Discussion in 'Installation/Configuration' started by RexMk1, Mar 18, 2015.

  1. RexMk1

    RexMk1 New Member

    Hello everybody, my problem is with the dns, and I do not know anything about dns... this is my first dns server, don't know what problem there is, only know that dig and named don't bring up anything and that email returns :

    status=deferred (Host or domain name not found. Name service error for name="domain".ro type=MX: Host not found, try again)

    Server is OpenSuse 13.1

    I have setup "a" and "mx" and "ns" in dns records in ispconfig's dns interface, and in the /var/lib/named I have a file called pri."domain".ro.err and it contains:

    $TTL 3600
    @ IN SOA ns1."domain".ro. tehnic."domain".ro. (
    2015031701 ; serial, todays date + todays serial #
    7200 ; refresh, seconds
    540 ; retry, seconds
    604800 ; expire, seconds
    86400 ) ; minimum, seconds
    mail 3600 A x.x.x.x
    "domain".ro. 3600 A x.x.x.x
    www 3600 A x.x.x.x 3600 MX 10 mail."domain".ro. 3600 NS ns1."domain".ro. 3600 NS ns2."domain".ro.

    sorry for the whole "domain" thing but it is not my domain and I don't have time to reach the owner and ask if he would let me post it...

    Thank you in advance!
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The a-records for the NS records are missing. if the ns is a subdomain of the same domain, then you have to add a-records for ns1 and ns2 as well.
  3. RexMk1

    RexMk1 New Member

    sry, I just used the dns wizard of the ispconfig... new guy :D so the subdomain is: "ns1 3600 A x.x.x.x" or is it "ns1."domain".ro. 3600 A x.x.x.x" ?
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats both the same, just short notation and long notation.
  5. RexMk1

    RexMk1 New Member

    added both ns1 & ns2 and it works, thank you so much!!! Such a simple thing :D
    one last q:
    If I add another domain for another website in ispconfig (say Domain2), do I have to create the ns for domain2 or do I have to use the ns from domain1? (I hope the question makes sense)
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats up to you, both options will work.
  7. RexMk1

    RexMk1 New Member

    Thank you! Thread closed :D

Share This Page