problem with dns .err file

Discussion in 'ISPConfig 3 Priority Support' started by muekno, May 1, 2019.

  1. muekno

    muekno Member HowtoForge Supporter

    I have multiple DNS zones working fine, tried to modify a IP address in one zone, did not change but got an err file, modifications on other zones works fine. At least I deleted the zone an receated ist, as there are no much record in it. Same problem, got .err file. Can't find whats going wrong, tripple checked. Contens of err file is here
    $TTL 3600
    @ IN SOA admin.gerdakloos.de. mk.muekno.de. (
    2019050112 ; serial, todays date + todays serial #
    7200 ; refresh, seconds
    540 ; retry, seconds
    604800 ; expire, seconds
    3600 ) ; minimum, seconds
    ;

    backen-mit-sauerteig.de. 3600 A 62.146.82.78
    www 3600 A 62.146.82.78
    backen-mit-sauerteig.de. 3600 MX 10 smtp1.gerdakloos.de.
    backen-mit-sauerteig.de 3600 NS admin.gerdakloos.de.
    backen-mit-sauerteig.de. 3600 NS ns2.gerdakloos.de

    It's realy not the first domain, have 8 other domains working fine.
    need help, thanks
    Rainer
     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

  3. muekno

    muekno Member HowtoForge Supporter

    Check tells me
    zone backen-mit-sauerteig.de/IN: NS 'ns2.gerdakloos.de.backen-mit-sauerteig.de' has no address records (A or AAAA)
    zone backen-mit-sauerteig.de/IN: not loaded due to errors.
    But the are at least two A records on for domain. itself and another for www, as you can sie in teh copy of the file above.
    Again, I have 8 other Domains running fine on the same primary and secondary nameservers, some of them I added or modified A records in the last days successfully. The problem startet when I tried to modify A Records, after that went wron multiple times I deleted the domain an recreated it, sam Problem.
    Thanks for help
    Rainer
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    When the NS records are a subdomain of the zone itself, then these ns records must exist as A-records in the zone. so when you have the domain example.com with ns1.example.com and ns2.example.com as DNS server, then you must add ns1 and ns2 as a-record too.

    But in your case, the problem is different. You missed adding a dot at the end of "backen-mit-sauerteig.de" in the first NS record and you missed adding a dot in the data section of the second NS record "ns2.gerdakloos.de".

    without these dots, the name is treated as a subdomain of the current zone.
     
  5. muekno

    muekno Member HowtoForge Supporter

    Oh thanks a lot, yes these Dots, I checked twice but oversaw the missing dots when recreating the domain. That does not explain the primary problem, not being able to modify the IP addresses of www and backen-mit-sauerteig.de. The domain exists sind min 6 years and worked fine all the time. But do not think about as ist works now. "You must not unterstand everything in the computer world" :)
    Thanks again
    Rainer
     

Share This Page