problem with cgi

Discussion in 'Server Operation' started by stero11, Jul 15, 2012.

  1. stero11

    stero11 New Member

    Hi
    I'm new user of server and ispconfig.
    I have a little problem (big for me)
    I have installed my server with Debian 6 and Ispconfig 3.
    I have opened my newwebsite. MY website work. Only one problem the cgi script.
    I have upload my cgi script with ascii mode. and chmod all file with 755.
    Now when i tried to check my script i have that answer : error404. file not here. and i have verified my file is inside the good directory.
    I think it's a problem of my ispconfig configuration.
    I have many options
    () CGI
    () SSI
    () Ruby
    () SuEXEC
    () SSL

    and a menu named "PHP"
    - disabled
    - Fast-CGI
    - CGI
    - ModPHP
    - SuPHP

    I have checked all solution... but i don't find the good.
    Now i don't see what to make.
    Somebody can help me please
    Regards
    Stephane
     
  2. falko

    falko Super Moderator ISPConfig Developer

    You must place CGI scripts in the cgi-bin directory (outside of the web directory) and make them executable.
     
  3. stero11

    stero11 New Member

    thanks... that work
     

Share This Page