Problem with BIND and ISPConfigs's DNS Manager

Discussion in 'Installation/Configuration' started by Nejko, Mar 22, 2006.

  1. Nejko

    Nejko New Member

    Hello,

    i solved all my problems except this one. I have problem with bind and ispconfig. When i create a domain (either master or slave), BIND goes down, and give an error like:
    and as soon as i delete domain from ispconfig, iw works normally again. If i create domain in Webmin, it works perfectly... I realy have to fix that, becouse i don't want to create all domains for my resellers and costumers manualy. Any suggestions?

    Have A Nice Day, Nejko
     
  2. falko

    falko Super Moderator

    It's not an ISPConfig problem, the problem is that Webmin and ISPConfig are interfering because both try to configure the same service. Either use ISPConfig or Webmin for configuring BIND, but not both.
     
  3. Nejko

    Nejko New Member

    Ok, i stopped Webmin, but it's same problem..... It just won't work. Is it possible, that i give u acess and u take closer look? It would be easier i guess...

    ?
     
  4. falko

    falko Super Moderator

    If you need this kind of support, have a look here: http://www.ispconfig.org/support.htm

    But the problem should be easy to solve: have a look at named.conf, then have a look at the error message, and also have a look at your zone files. Normally you should see then where the problem is.
     
  5. Nejko

    Nejko New Member

    Look, i created 123.nero-server.com and i get:
    And If i look in it's zone file, there's notjing in it, but in named.conf is:
    and the working domain created in webmin(nero-server.com) is:
    Why is the file url diffarent?
     
  6. falko

    falko Super Moderator

    You shouldn't use subdomains in zones. Use

    Code:
    zone "nero-server.com" {
      type master;
      file "pri.nero-server.com";
    };
    instead.
    What's in your named.conf?
     
  7. Nejko

    Nejko New Member

    options {
    pid-file "/var/named/chroot/var/run/named/named.pid";
    directory "/var/named";
    auth-nxdomain no;
    /*
    * If there is a firewall between you and nameservers you want
    * to talk to, you might need to uncomment the query-source
    * directive below. Previous versions of BIND always asked
    * questions using port 53, but BIND 8.1 uses an unprivileged
    * port by default.
    */
    // query-source address * port 53;
    };

    //
    // a caching only nameserver config
    //
    zone "." {
    type hint;
    file "named.ca";
    };

    zone "0.0.127.in-addr.arpa" {
    type master;
    file "named.local";
    };

    zone "123.nero-server.com" {
    type master;
    file "pri.123.nero-server.com";
    };


    //// MAKE MANUAL ENTRIES BELOW THIS LINE! ////



    zone "nero-server.com" {
    type master;
    file "/var/named/nero-server.com.hosts";
    };
     
  8. falko

    falko Super Moderator

    Does /var/named/pri.123.nero-server.com exist? What's in it?
     
  9. Nejko

    Nejko New Member

    [root@localhost ~]# cd /var/named/pri.123.nero-server.com
    -bash: cd: /var/named/pri.123.nero-server.com: No such file or directory
    [root@localhost ~]# cd /var/named/
    [root@localhost named]# dir
    chroot localdomain.zone named.broadcast named.ip6.local named.zero
    data localhost.zone named.ca named.local slaves
    [root@localhost named]#
     
  10. falko

    falko Super Moderator

    You must create the zone file /var/named/pri.123.nero-server.com then.
     
  11. Nejko

    Nejko New Member

    Yes, i understand that, but.. why does webmin create a zone as:

    file "/var/named/nero-server.com.hosts";

    and ispconfig as:

    file "pri.123.nero-server.com";

    And why should i create it manualy... i thought, that i can do everything in ISPConfig... :S
     
  12. falko

    falko Super Moderator

    Because Webmin uses absolute paths; the other zone uses relative paths (relative to directory "/var/named"; in your named.conf).

    Because you created the named.conf entry for that zone manually and not with ISPConfig.
    If you want to do it with ISPConfig, then why did you edit named.conf manually? Makes no sense.
     
  13. Nejko

    Nejko New Member

    Look, i deleted everything i created in webmin, and then tried in ISPConfig, but same happaned. I want so solve that...
     
  14. till

    till Super Moderator

    You can not use webmin and ISPConfig to configure the same service! You will have to decide wethere you like to use webmin or ISPConfig.
     
  15. Nejko

    Nejko New Member

    I decided, ISP Config. What do do to fix that?

    BTW; i disabled DNS Manager in Webmin :)
     
  16. falko

    falko Super Moderator

    Delete the pri.123.nero-server.com zone, and then create a nero-server.com zone with ISPConfig's DNS Manager.
     
  17. Nejko

    Nejko New Member

    done, but same... isp creates that pri... bind won't start :S
     
    Last edited: Mar 26, 2006
  18. falko

    falko Super Moderator

    You must create the zone nero-server.com in ISPConfig, not 123.nero-server.com. 123 is a subdomain of nero-server.com.
     
  19. Nejko

    Nejko New Member

    That's what I'm saying.. If i create nero-server.com, bind won't start :S

    Look in your Inbox...
     
  20. Nejko

    Nejko New Member

    So how to fix that? When i create domain in ISP Config bind gives me start error, like described on first page... What to do? :S
     

Share This Page