Problem with /bin/sh /bin/runAV

Discussion in 'Installation/Configuration' started by maxbrunner, Mar 1, 2013.

  1. maxbrunner

    maxbrunner New Member

    I'm a new user of ISPConfig (an excelent software, by the way) and I'm facing a problem with /bin/sh.

    I've installed ISPConfig in a Amazon EC2 Instance with Ubuntu 12.04, following this tutorial here in howtoforge:

    Everything is working fine, but I have some sites with Joomla CMS 1.6 (yes, an old version, I know) and when I try to do file uploads for upgrade Joomla or install components I have a 500 internal server apache error. The apache error log says that:

    "/bin/sh: /bin/runAV: No such file or directory"

    I think that this is related to the change of /bin/dash for /bin/bash, but I don't know what do to. Google didn't helped me either. Someone can help me? Thanks in advance.

    [sorry about my poor Brazilian english :)]
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Which php mod do you use for the website? The recommended mode for cms systems is php-fcgi or php-fpm and suexec must be on, otherwise uploads and updates may fail.
  3. maxbrunner

    maxbrunner New Member

    That's not the problem... I'm using fcgi + suexec forced
  4. maxbrunner

    maxbrunner New Member

    I tried to use php-FQM and it worked! Thanks..

    Are there any security issues in using FQM instead of fastcgi?
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    No. Just ensure tht you have suexec enabled.
  6. maxbrunner

    maxbrunner New Member

    Ok, thanks a lot!

Share This Page