Problem with Awstats log

Discussion in 'Installation/Configuration' started by Captain, Sep 23, 2009.

  1. Captain

    Captain Member

    Hello!

    After update ISPConfig to 2.2.33. ISPConfig include Awstats statistic.
    But its dont work. Statistic is empty. I see only "www.mydomain.com"
    What I need to configured?

    Big thnks.
     
  2. jnsc

    jnsc rotaredoM

  3. Captain

    Captain Member

    :( Yes. But didnot work.
     
    Last edited: Sep 23, 2009
  4. nikopol

    nikopol New Member

    After the step above I did:

    /usr/src/ISPConfig_awstats_pkg/install.sh

    and everything was working fine again. If you don't want to wait until the awstats cron job is running at 4:00 you can force it with

    /root/ispconfig/php/php /root/ispconfig/scripts/shell/awstats.php

    All "web's" are running no awstats as webalizer statistics. You can find this new feature unter the option tab in ispconfig 2.2.33.

    Because the webalizer statistics is now stored in /var/www/webX/web/webalizer and not anymore in /var/www/webX/web/stats I did a

    cp -R /var/www/webX/web/webalizer/ /var/www/webX/web/webalizer.backup

    cp /var/www/webX/web/stats/* /var/www/webX/web/webalizer

    If you did the above commands as root you should do:

    chown -R webX_user:webX webalizer (replace webX_user and webX with the user and group of your ispconfig web)

    start the webalizer statistics generation if you don't want to wait until the cronjob is started:

    /root/ispconfig/php/php /root/ispconfig/scripts/shell/webalizer.php

    I know this is of course only a solution if you are running a few webs with your ispconfig installation, but it fixed it for me.

    It would be fine if someone could explain how to setup webalizer and awstats statistics after upgrading from ispconfig 2.2.32 to 2.2.33 for all webs with a script for example.

    It would also be fine to get a howto on deinstalling the /usr/src/ISPConfig_awstats_pkg/ after the ispconfig 2.2.33 installation to use the new integrated ispconfig awstats feature standalone.

    Thanks + Regards,

    Robert
     
    Last edited: Sep 24, 2009
  5. jnsc

    jnsc rotaredoM

    for the webalizer problem, there is a solution in this thread

    http://howtoforge.com/forums/showpost.php?p=204748&postcount=19


    /usr/src/ISPConfig_awstats_pkg/ is only the install directory, so it can be deleted. For the rest, as the destination directories are the same, in both methods, there should be no "remaining files" from the old installation method.
     
  6. Captain

    Captain Member

    I 'am re-install ISPConfig and Awstats start working, but didnot see images in Awstat.
    What I can do?
     
  7. jnsc

    jnsc rotaredoM

    Yes this is a bug was already reprted, i will have to look why it does not work on update. As a workaround you can add this to you apache configuration
    Code:
    ### AWStats Section ###
    Alias /icon "/home/admispconfig/ispconfig/tools/awstats/wwwroot/icon/"
    ### End of AWStats Section ###
    
     
  8. Captain

    Captain Member

    Thnk you very much. Now it works very well.
    We too have this problems when we install our products.
    :)
     

Share This Page