Problem With API Remote User Connections on SSL

Discussion in 'Installation/Configuration' started by CubAfull, Jun 12, 2012.

  1. CubAfull

    CubAfull Member

    Hello experts,

    After spending almost 2 days without sleep I think it's time to ask for help.

    I have a server with ISPConfig and Roundcube working perfectly, but I have a big problem with the connection between the server and the roundcube plugin ispconfig3_account using secure connection (SSL). If I use an unsecured connection (disabling ssl in ispconfig), everything works fine, can change password etc.

    I tried reinstalling ispconfig, roundcube, plugins, re-configuring the plugin using the server ip... obtaining always the same result "Soap Error: Could not connect to host"

    I have a valid certificate, and this did not happen some time ago, the problem began after starting to use the SNI or after activating ssl in another domain (I think), this server have only one IP

    I really appreciate it if someone could help me with this problem, do not know what else to do :(


    $rcmail_config['identity_limit'] = false;
    $rcmail_config['remote_soap_user'] = 'remote_user';
    $rcmail_config['remote_soap_pass'] = 'remote_pass';
    $rcmail_config['soap_url'] = '';
    Thank you for your time.
  2. CubAfull

    CubAfull Member

  3. falko

    falko Super Moderator ISPConfig Developer

    I guess this happened because an SSL cert is bound to a domain/hostname, not to an IP. Maybe there was a certificate warning when you used the IP.

Share This Page