Problem whit FastCGI: incomplete headers

Discussion in 'Server Operation' started by tokar86a, Dec 31, 2014.

  1. tokar86a

    tokar86a Member

    Hi

    I end up whit lots of this in m error log:

    [Wed Dec 31 13:49:21.784031 2014] [fastcgi:error] [pid 21338] [client 178.62.80.152:59049] FastCGI: comm with server "/var/www/clients/client0/web4/cgi-bin/php5-fcgi-*-80-myabdllife.com" aborted: idle timeout (300 sec)
    [Wed Dec 31 13:49:21.784664 2014] [fastcgi:error] [pid 21338] [client 178.62.80.152:59049] FastCGI: incomplete headers (0 bytes) received from server "/var/www/clients/client0/web4/cgi-bin/php5-fcgi-*-80-myabdllife.com"

    But i dont know how i can fix this?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you see any errors in the php fpm log file in /var/log/ ?
     
  3. tokar86a

    tokar86a Member

    I found this kind of info in another error log file for apache:

    [Wed Dec 31 11:48:24.774948 2014] [cgi:error] [pid 17069] [client 200.111.163.37:42065] script not found or unable to stat: /usr/lib/cgi-bin/authLogin.cgi
    [Wed Dec 31 14:03:09.522645 2014] [cgi:error] [pid 22513] [client 118.211.92.48:53018] script not found or unable to stat: /usr/lib/cgi-bin/authLogin.cgi


    This is what i find in the php5-fpm.log

    [29-Dec-2014 20:14:10] NOTICE: configuration file /etc/php5/fpm/php-fpm.conf test is successful

    [31-Dec-2014 14:37:16] NOTICE: configuration file /etc/php5/fpm/php-fpm.conf test is successful
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The cgi error is most likely not related to your problem.

    Please try to add a simple info.php file

    PHP:
    <?php
    phpinfo
    ();
    ?>
    in the website and open it with a browser. Does it show the phpinfo output or do you get the same php-fpm error.
     
  5. tokar86a

    tokar86a Member

    Yes it shows the phpinfo outpost. So is it not any problem then?
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Then the problem is most likely that there are some operations in your website like web crons or similar that take more then 300 seconds and therefor trigger a timeout. If you dont experence any malfunctions in the site, then you can ignore that.
     
  7. tokar86a

    tokar86a Member

    Can i somehow increase this 300 to something else? I get this kind of error in my log allot. So it should be nice to get it fix.
     
  8. erama

    erama New Member

    I have de some problem, buy when a try show the phpinfo I get same error 500 and my log file al see this:
    [fastcgi:error] [pid 25668] [client 192.1.3.3:24575] FastCGI: incomplete headers ( 0 bytes) received from server "/var/www/clients/client1/web35/cgi-bin/hhvm-fcgi-*-80-domain.com"

    I'm using hhvm with fastcgi
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    This means that the hhvm server did not answer for the fastcgi request. It might be not installed correctly or it is not running.
     
  10. erama

    erama New Member

    thank you for help me, but I can't resolve it. It is rare but when I reset my server HHVM start to run and I can see phpinfo()
    [​IMG]
    [​IMG]
    But my site isn't run and I see the same error in the log file:

    Code:
    [fastcgi:error] [pid 12658] (2)No such file or directory: [client 190.88.88.88:24961] FastCGI: failed to connect to server "/var/www/clients/client1/web35/cgi-bin/php5-fcgi-*-80-domain.com": connect() failed
    [Tue Jul 26 20:41:01.575038 2016] [fastcgi:error] [pid 12658] [client 190.88.88.88:24961] FastCGI: incomplete headers (0 bytes) received from server "/var/www/clients/client1/web35/cgi-bin/php5-fcgi-*-80-domain.com"
    This is my vhost.conf
    Code:
    <Directory /var/www/domain.com>
            AllowOverride None
                    Require all denied
            </Directory>
    
    <VirtualHost *:80>
    
                                        DocumentRoot /var/www/clients/client1/web35/web
                         
            ServerName domain.com
            ServerAlias www.domain.com
            ServerAdmin [email protected]
    
            ErrorLog /var/log/ispconfig/httpd/domain.com/error.log
    
            Alias /error/ "/var/www/domain.com/web/error/"
            ErrorDocument 400 /error/400.html
            ErrorDocument 401 /error/401.html
            ErrorDocument 403 /error/403.html
            ErrorDocument 404 /error/404.html
            ErrorDocument 405 /error/405.html
            ErrorDocument 500 /error/500.html
            ErrorDocument 502 /error/502.html
            ErrorDocument 503 /error/503.html
    
            <IfModule mod_ssl.c>
            </IfModule>
    
            <Directory /var/www/domain.com/web>
                    # Clear PHP settings of this website
                    <FilesMatch ".+\.ph(p[345]?|t|tml)$">
                            SetHandler None
                    </FilesMatch>
                    Options +FollowSymLinks
                    AllowOverride All
                                    Require all granted
                            </Directory>
            <Directory /var/www/clients/client1/web35/web>
                    # Clear PHP settings of this website
                    <FilesMatch ".+\.ph(p[345]?|t|tml)$">
                            SetHandler None
                    </FilesMatch>
                    Options +FollowSymLinks
                    AllowOverride All
                                    Require all granted
                            </Directory>
    
    
    
    
    
            <IfModule mod_fastcgi.c>
                    <Directory /var/www/clients/client1/web35/cgi-bin>
                                            Require all granted
                                        </Directory>
                    <Directory /var/www/domain.com/web>
                        <FilesMatch "\.php[345]?$">
                            SetHandler hhvm-fcgi
                        </FilesMatch>
                        <FilesMatch "\.hh$">
                            SetHandler hhvm-fcgi
                        </FilesMatch>
                    </Directory>
                    <Directory /var/www/clients/client1/web35/web>
                        <FilesMatch "\.php[345]?$">
                            SetHandler hhvm-fcgi
                        </FilesMatch>
                        <FilesMatch "\.hh$">
                            SetHandler hhvm-fcgi
                        </FilesMatch>
                    </Directory>
                    Action hhvm-fcgi /hhvm-fcgi virtual
                    Alias /hhvm-fcgi /var/www/clients/client1/web35/cgi-bin/hhvm-fcgi-*-80-domain.com
                    FastCgiExternalServer /var/www/clients/client1/web35/cgi-bin/hhvm-fcgi-*-80-domain.com -idle-timeout 300 -socket /var/run/hhvm/hhvm.web35.sock -pass-header Authorization
            </IfModule>
    
    
            # add support for apache mpm_itk
            <IfModule mpm_itk_module>
                AssignUserId web35 client1
            </IfModule>
    
            <IfModule mod_dav_fs.c>
            # Do not execute PHP files in webdav directory
                <Directory /var/www/clients/client1/web35/webdav>
                    <ifModule mod_security2.c>
                        SecRuleRemoveById 960015
                        SecRuleRemoveById 960032
                    </ifModule>
                    <FilesMatch "\.ph(p3?|tml)$">
                        SetHandler None
                    </FilesMatch>
                </Directory>
                DavLockDB /var/www/clients/client1/web35/tmp/DavLock
                # DO NOT REMOVE THE COMMENTS!
                # IF YOU REMOVE THEM, WEBDAV WILL NOT WORK ANYMORE!
          # WEBDAV BEGIN
                # WEBDAV END
            </IfModule>
    
    
    
    </VirtualHost>
    
    
    
    
    I have configured my server by following this tutorial:
    https://www.howtoforge.com/tutorial...8-4-jessie-apache-bind-dovecot-ispconfig-3-1/

    Do you know where I can start looking for a solution?

    Thank you.
     
    Last edited: Jul 26, 2016
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    Are you sure that you started / restarted the right hhvm instance? Each website has its own HHVM instance with a start script in /etc/init.d/
     
  12. erama

    erama New Member

    Yes, I'm sure. I am doing /etc/init.d/hhvm_web[number] restart .
    Today I updated HHVM to last versiĆ³n and all sites stopped working.

    When change HHVM to PHP-FPM website starts to work fine then I go back to change PHP-fpm to HHVM and continues to function well.

    Also I updated ISPConfig to 3.1 rc 1
    I don't know where can I look for the error...
     

Share This Page