Problem when upgrade to 2.2.21 on Ubuntu 7.1

Discussion in 'Installation/Configuration' started by oriongr, Feb 14, 2008.

  1. oriongr

    oriongr Member

    I have an Ubuntu 7.1 server with ISPconfig 2.2.19 that running fine.
    I wanted to upgrade to 2.2.21 I downloaded the tar, untar it and run the setup

    and after
    ########## INSTALLATION ##########

    Preparing files. Please wait a moment...

    but then it takes ages. It seems that is working but nothing happens.
    In another terminal I can see that gzip proccess takes aup to 66.5% of CPU
    but nothing happens. Any ideas?

    ( I performed the same operation with Debian 4 and everything worked fine)

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please check with:

    df -h

    that you have enough free space on all partitions. Additionally, you should remove all files and folders from the directory /home/admispconfig/ispconfig/temp/ except of the webmail folder.

    Before yu try to update again, run the command:

    mkdir /root/ispconfig
  3. oriongr

    oriongr Member

    More than enough...

    now I go one step further...
    cp: cannot stat `/root/ispconfig/httpd/conf/ssl.*': No such file or directory


    from ps uax
    root 6821 1.4 0.1 3464 1096 pts/0 D+ 11:34 0:01 tar -pczf home_admispconfig.tar.gz /home/admispconfig/
    root 6822 68.1 0.0 1912 660 pts/0 S+ 11:34 0:55 gzip
  4. till

    till Super Moderator Staff Member ISPConfig Developer

  5. oriongr

    oriongr Member

    /root/ispconfig/httpd/conf/ssl.key/server.key2: No such file or directory

    Did I remove something that I did not suppose to?

    The installationd proceeded but with an exit error
    ERROR: The PHP binary coming with ISPConfig does not work properly on your system! The installation routine stops here!

    I am confused.. Thanks for the help Till
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    This is not the error message that caused the installation to stop! Please post the first error not the last error messages that you got on the screen.
  7. oriongr

    oriongr Member

    I removed ispconfgi_install and untared the ISPconfig tar again.
    I ran setup and this time worked!

    That was strange...
    Thanks for the help
  8. bernholdt

    bernholdt Member

    Same prpb on debian 4

    It helped me to clear the tmp as suggested tnx for the help :D

Share This Page