Problem when deleting websites

Discussion in 'Developers' Forum' started by Croydon, Aug 15, 2012.

  1. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    There seems to be a problem in current svn version (don't know about earlier versions) when deleting websites.

    rm: Entfernen von „/var/www/clients/client1/web2/web“ nicht möglich: Keine Berechtigung

    and same message with all the folders in the web2 dir.

    ls -ld /var/www/clients/client1/web2/web
    drwx--x--- 2 web2 client1 4096 15. Aug 17:56 /var/www/clients/client1/web2/web

    It seems even root cannot delete this, I tried a rm -r and rm -rf but same error.

    After a few tests I realized that the web1 and web2 directories have the immutable bit set (chattr +i web2), so it can online be deleted if I do a chattr -i web2 first.
    It seems that this step is missing on deleting a web (maybe on renaming or moving, too), so a web does not get deleted, including its vhost file.

    This is no problem as long as no one tries to recreate a web with the same domain later on. If you try this you mess up your installation as the new web is not created correctly (logfile path missing, wrong vhost file).
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, the current version has a feature called "web folder protection" which can be set under system > server config. Seems as if I missed to unprotect the folders before they get deleted. I added this to the bugtracker.

Share This Page