Problem: Virtual Users With Postfix (by thim)

Discussion in 'HOWTO-Related Questions' started by nataklug, Feb 20, 2007.

  1. nataklug

    nataklug New Member

    Hello all,

    I am new to this comunity and I am liking the style it is made. I found an interesting tutorial:

    http://www.howtoforge.com/virtual_users_postfix_courier_mailscanner_clamav_centos

    I made everything that is in the howto but, when I try to authenticate a client (via POP3) this message appear into my /var/log/debug and /var/log/maillog:

    Code:
    Feb 20 09:53:46 ns2 authdaemond: received auth request, service=login, authtype=login
    Feb 20 09:53:46 ns2 authdaemond: authmysql: trying this module
    Feb 20 09:53:46 ns2 authdaemond: SQL query: SELECT username, password, password, 9991, 9991, /home/ispsis_postfix, CONCAT("/home/ispsis_postfix",maildir) , CONCAT(quota,'S'), name, "" FROM mailbox WHERE username = "[email protected]"
    Feb 20 09:53:46 ns2 authdaemond: mysql_query failed, reconnecting: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '/home/ispsis_postfix, CONCAT("/home/ispsis_postfix",maildir) , CONCAT(quota,'S')' at line 1
    Feb 20 09:53:46 ns2 authdaemond: mysql_query failed second time, giving up: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '/home/ispsis_postfix, CONCAT("/home/ispsis_postfix",maildir) , CONCAT(quota,'S')' at line 1
    Feb 20 09:53:46 ns2 authdaemond: authmysql: TEMPFAIL - no more modules will be tried
    Besides that I have a problem when deleting an account using PostfixAdmin interface. I made the file (maildirdel.sh) but this is not removing the directory where it should be and, when I create it should be like .../domain.tld/user but it is creating maildir as ...[email protected]

    I would be very happy for some help in this problem.

    ---------------- EDITED PART BELLOW --------------------
    So I have made the system works... Now I can receive and send emails BUT there is no authentication working. Neither TLS (I have no cash to buy a license, so I generate one using this command bellow), neither SMTP auth. I don't know anymore what can I have done wrong is this part:

    Code:
    [b]Command to generate key/csr -> pem[/b]
    openssl req -new -outform PEM -out smtpd.cert -newkey rsa:2048 -nodes -keyout smtpd.key -keyform PEM -days 3650 -x509
    cat smtpd.key smtpd.cert > smtpd.pem
    When I try to use my Thinderbird to receive email from the server my mail client returns that Thunderbird and my server could not comunicate becouse they don't have comon algoritms. If I use the command to generante ca.key and ca.crt (from the tutorial) and mix this both into ca.pem them my Thinderbird waits long to return that the time has exceded.

    I find this in the log, but could not understand:

    Code:
    Feb 20 16:23:37 ns2 pop3d: Enter PEM pass phrase:DEBUG: Connection, ip=[::ffff:172.30.0.213]
    Feb 20 16:23:37 ns2 pop3d: couriertls: accept: error:1408A10B:SSL routines:SSL3_GET_CLIENT_HELLO:wrong version number
    Feb 20 16:23:37 ns2 pop3d: Disconnected, ip=[::ffff:172.30.0.213]
    Some other info:

    CentOS Server 4.4
    mysql-server-5.0.27-1.el4.centos
    mysql-5.0.27-1.el4.centos
    postfix-2.2.10-1.RHEL4.2.mysql_pgsql.c4
    All other packages are the same as the tutorial (just my system is i386)

    ---- SECOND EDIT BELLOW ----

    I have made many tests and came to realize that all the problems I have was about misconfiguration and/or do not read all the text. One of the problems was solved using just an ' into a linha of code. Other problem I solved by re-reading the how-to and seeing that there is and error in one script (maildirmake.sh and maildirdel.sh).

    The other problem, about not authenticate smtp, was becouse I have had only tested with a local address. So, when I am sending from @mydomain.tld to @mydomain.tld the server does not ask for authentication. I will look forward to solve this problem.

    Thank you all that read the problem. Even with no answers... ;)

    Att,

    Nataniel Klug .'.
    Cyber Nett
    Brazil
     
    Last edited: Feb 20, 2007
  2. thim

    thim New Member

    I'm glad you got everything working.

    I've tried to make the howto so complete as possible.
    But you have to read it 2x to get it all right :)

    Thnx 4 posting your comment
     

Share This Page