Problem updating (MySQL issue)

Discussion in 'Installation/Configuration' started by Youko, Nov 27, 2010.

  1. Youko

    Youko New Member

    [Solved] Problem updating (MySQL issue)


    When I try to update ISPCOnfig 3, I ge tthe following errors:

    Warning: mysql_connect(): Access denied for user 'root'@'localhost' (using password: YES) in /tmp/ispconfig3_install/install/lib/mysql.lib.php on line 78
    Fatal error: Cannot use string offset as an array in /tmp/ispconfig3_install/install/lib/update.lib.php on line 98
    I am running the update command as root.

    Now, I most likely know what the first error is.
    My ISP had made the initial ISPConfig 3 installation.

    Later, I updated my MySQL root password. However, according to
    the upgrade guide, the updater should ask me the root password for
    MySQL which it does not which leads me to think the info is stored in some
    file, but I can't find it anywhere! Help would really be appreciated!

    For the second error I have no clue. :confused:
    Last edited: Nov 28, 2010
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The mysql root password has to be changed in the file /usr/local/ispconfig/server/lib/mysql-clientdb.conf when you change the root password of the mysql server. Otherwise ispconfig will not work properly anymore and is e.g. unable to create new databases.
  3. Youko

    Youko New Member

    Thank you so much! This was driving me insane.
  4. mascoxx

    mascoxx New Member


    I've got the same issues, but the credentials are correct because I'm also able to login in manually!
    In my environment are three machines. One of them is the master service which also provides the admin panel. The other both are web- and mailservers.
    The master update was successful, but then I've tried to update the second one - with this error as described by Youko.

    Till, do you have an idea what's going wrong?

    Thanks and regards,

Share This Page