Problem updating ISPconfig: mysql: unknown variable 'innodb_buffer_pool_size = 1G'

Discussion in 'Installation/Configuration' started by Milly, Nov 19, 2020.

  1. Milly

    Milly Member

    Hi I am getting the following error when trying to update ISPconfig from 3.1 to 3.2:


    In the /etc/mysql/mariadb.conf.d/50-server.cnf file all the "general_log_file = /var/log/mysql/mysql.log" are commented.

    It has been working perfect for 5 months with The Perfect Server - Debian 10 guide, Is it possible that it is due to having it on a Raspberry Pi 4GB (ARM) with Raspbian?

    To update I do it with the guide of https://www.howtoforge.com/updating-ispconfig-3-1-to-ispconfig-3-2/ where the only thing that I cannot install in rar, but I don't know if it is part of the problem?

    If the mariadb status is necessary, which always has the following information:




    Thank you

     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Was the original version latest 3.1 before upgrade? Upgrade to 3.2 is best supported from 3.1.15.
    Maybe innodb_buffer_pool_size is no longer in recent versions of mariadb? How old is this installation and did it have older version of mysql or mariadb before? Did you upgrade also the OS?
     
  3. Milly

    Milly Member

    Hi @Taleman
    - Sorry, I was not specified, the current version of ISPconfig is 3.1.15p3

    - The installation takes 5 months, only normal updates (update, upgrade) and kernel (dist-upgrade).

    - The installation is Raspbian GNU/Linux 10.6 (buster) Linux 5.4.72-v7l + armv7l

    - I have maridb, but it is Interesting, I try to see the installed version but it gives an error:
    # mariadb --version
    mariadb: unknown variable 'innodb_buffer_pool_size = 1G'


    # apt install mariadb-server
    mariadb-server is already the newest version (1: 10.3.25-0 + deb10u1)
    .

    Even with that mariadb error, ISPconfig always works fine, emails and even nextcloud works without problems.


    Note:
    I have another same installation on another PC and ISPconfig updated without problem:
    # mariadb --version
    mariadb Ver 15.1 Distrib 10.3.25-MariaDB, for debian-linux-gnu (x86_64) using readline 5.2


    Thanks
     
  4. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Remove or comment out that innodb_buffer_pool_size setting.
     
    Th0m likes this.
  5. Milly

    Milly Member

    Thank you @Taleman, that was the solution to update.

     
  6. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    That setting belongs in the mysqld section, not mysql.
     
    Last edited: Nov 20, 2020

Share This Page