Problem -> The Perfect Setup - Ubuntu 6.10 Server

Discussion in 'HOWTO-Related Questions' started by actionplant, Jan 17, 2007.

  1. actionplant

    actionplant New Member

    I haven't seen another thread with this problem so sorry if this is a repost.

    I've had a problem in a couple of different areas of the install. When I try to apt-get proftpd I get the following error:

    Package proftpd-common is a virtual package provided by:
    proftpd 1.3.0-9ubuntu0.1
    You should explicitly select one to install.
    E: Package proftpd-common has no installation candidate

    This is weird. Why is it referencing E: when I've commented the local drive out as per editing the sources list on p.3? And how do I get this package? I'm getting almost the exact same error with linux-kernel-headers per the first apt-get on p.4. Everything else has worked like a charm.


    EDIT - I just found the solution for the proftpd problem via this thread:

    Still unsure on the linux-kernel-headers though.
    Last edited: Jan 17, 2007
  2. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    E: stands for Error:, not for your E: drive ......
    Remove the common part and issue:
    apt-get install proftpd
  3. actionplant

    actionplant New Member

    *smacks forehead*

    Sorry, I knew that. I shouldn't try to do this when I'm on cold medication...

  4. actionplant

    actionplant New Member

    Whole new problem.

    In 19.1 A Note On SuExec I installed per the directions which said:

    Which is confusing, but I followed it by not changing the web root. In ISPConfig when I create a new user and site it's all weird though. The user and site are created with the folder "web" in "home" (I logged in to that user on the server to verify this) even though in Management -> Server -> Settings -> Web it said the Document Root is /home/www

    So that's where I uploaded the website's files, then I went and deleted the generic "wecome" index.html, but on page reloads I continued to get the "welcome" page, meaning it must be referenced from somewhere else.

    Does this make sense to anyone? I got a hilarious 404 when I changed the name of the folder in "home" for that user from "web" to "www", "The requested URL / was not found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request."

    Pretty funny actually. So anyway, I can type specific filenames and pull them up, including /index.html...but the root STILL pulls up the damn "welcome" page which makes no sense to me.
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    You must have set the folder to /var/www instead of /home/www in the ISPConfig installer during setup in expert mode if you want to use SuEXEC. SuEXEC can not be used when you select /home/www as root folder for your website documents.

    But the handling of html files is not affected by the SuEXEC setting at all. Please check that your website has the correct domain and IP address and if you get any additional errors in the error log of the website.

Share This Page