Problem sharing a directory

Discussion in 'Installation/Configuration' started by conductive, Feb 7, 2012.

  1. conductive

    conductive Member

    I am running ISPconfig3 Debian Squeeze perfect server and wanted to share a complete directory. I ran chmod 777 on it and I still get

    ERROR 403 - Forbidden!

    In many ways this is good for security since I do not need to have an index.html in other directory’s.

    Is is possible to share directory’s and/or is it a bad idea? I do not think I have any .htaccess on a fresh directory or do I?

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Sharing directories is a bad idea security wise. Each website runs under its own user and group to separate the sites and by settings a directory to chmod 777, you allow hackers to infect allyour sites when one site gets hacked.
  3. conductive

    conductive Member

    Maybe I said this wrong.

    Under a site if I wanted to share a directory of pictures how would I do it?

    chmod 777 was only for troubleshooting, but I still should be able to share a directory of pictures like this right?

    if not I would have to make a link for every picture, database or other which is lots of work.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    You mean that you want to get a list of all files displayed in the browser that are in that directory? This does not depend on the dirctory permissions, you should undo the chmod 777 and reset it to e.g. chmod 755

    Then add a file named:


    in the pictures folder with the following content:

    Options +Indexes
  5. conductive

    conductive Member


    I will just delete, re-upload and add the .htaccess

    Thanks and keep up the good work.
  6. conductive

    conductive Member

    How do you share foldere in Nginx?
    Adding the above .htaccess file does not seem to be working.
  7. conductive

    conductive Member

    I was able to fix the problem by adding the Nginx directive as follows:

    location  /shared_folder  {
      autoindex  on;

Share This Page