Problem setting external mailserver

Discussion in 'Installation/Configuration' started by erk, May 18, 2006.

  1. erk

    erk New Member HowtoForge Supporter

    Hi!

    I dicovered a problem with setting external mailserver. I have set external mailserver for one of my hosted domains but the mail still did not work. I discovered that the domain was still in /etc/postfix/local_host_names.
    I logged in to the web interface again and checked the setting and it was set for external mailserver. Strange. The mystery deepens as I check the database in table isp_isp_domain. There I find that isp_isp_domain.domain_local_mailserver = 1 for all domains.
    Doing a manual update on this table to domain_local_mailserver=0 for the domain in question solved the problem but I don't understand how this could happen. Should not the setting of domain_local_mailserver be what is reflected in the web interface?
    Is this a bug that has been resolved in later releases?

    Best regards,

    Erik

    BTW. I'm running ISPConfig 2.1.2 on Debian Sarge
     
    Last edited: May 18, 2006
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You will have to set the mailserver to external in the website settings and in the settings for every co-domain of this website that is on the external mailserver too!
     
  3. erk

    erk New Member HowtoForge Supporter

    I'll admit that I forgot to check the settings for the co-domains but that still does not explain why the main domain had external mailserver in the web interface and domain_local_mailserver = 1 in the database. Or do you have to set external mailserver for both the main domain AND all co-domains for the setting to work?

    Best regards,

    Erik
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes. The logic behind that is very simple.

    The website has the domain www.example.com. If you set mailserver to external in the website, the local server does not accept mails for ...@www.example.com anymore. If you have a co-domain example.com (with empty host), you will have to set this to extaernal mailserver if you dont want to get emails for this domain (example.com) on the local mailserver.
     
  5. erk

    erk New Member HowtoForge Supporter

    Great! Thanx a bunch.
    I'm happy that that is all sorted out then.
    I wonder if I should get a pair of reading glasses or if this is something that might be good to add to the manual.

    Best regards,

    Erik
     

Share This Page