Problem sending mail to certain addresses.

Discussion in 'Installation/Configuration' started by shackrat, Jul 30, 2006.

  1. shackrat

    shackrat New Member

    I'm having trouble sending mail to certain e-mail addresses, including anyone who is a Time Warner RR customer or employee. I've narrowed the problem down to the fact that the messages are being sent from [email protected] instead of the contact e-mail specified in phpBB.

    This is what I'm seeing in my logs:

    Jul 30 00:57:46 localhost postfix/smtp[11539]: 6EB2C690042: host clmboh-02.mgw.rr.com[65.24.7.66] said: 451 #4.1.3 Domain of sender address <[email protected]> does not resolve (in reply to MAIL FROM command)

    I had the same exact site running on a Site5 server before I moved it a few days ago just fine, and it would send e-mail to those same folks. It's the first site I've moved to this dedi that's running ISPConfig, and I thought I was ready to go. :(

    Please help!
     
  2. shackrat

    shackrat New Member

    Well I created an SPF record with anubis.hideoutsites.com as an additional MXand it works fine now. But I'm still concerned that e-mail is not being sent from the correct domain through php.

    Any ideas?
     
  3. falko

    falko Super Moderator ISPConfig Developer

    The DNS record looks fine now. :)

    You might have to check PHP's mail() function in your PHP applications. You can set the sender's email address with the additional headers parameter: http://de3.php.net/manual/en/function.mail.php
     

Share This Page