Problem sending and receiving mail

Discussion in 'Server Operation' started by usr_bin_env, Mar 16, 2012.

  1. usr_bin_env

    usr_bin_env New Member

    Hi everyone,

    I have setup postfix and dovecot for my mail system, but i'm having a major problem sending and receiving mail as well as authentication on outgoing mail too. My email mx records have been setup and they are work fine as when i telnet mail.example.com 110 and i login with [email protected] it works great also with 143 it worked great. When i try telnet mail.example.com 25 and try to send mail to my @gmail.com (only one i have tried at the moment) with RCPT TO the message appears "Relay access denied" then when i put my email [email protected] has the RCPT TO the message "Recipient address rejected: User unknown in host recipient table". Finally i have setup my email client and it seems to login to incoming mail as the login does work through telnet, but the outgoing appears says "mail.example.com refused to allow a connection on the default ports" even through the ports are open and i can telnet into the port 25 apart from the messages above.

    Any idea what could be the cause, if anyone wants the files i can post them through.

    Many Thanks
     
  2. usr_bin_env

    usr_bin_env New Member

    Just a update i got the email client to send the mail but it does not come through, but still comes up with message "Relay access denied" via telnet and i can not send mail to myself.
     
    Last edited: Mar 16, 2012
  3. usr_bin_env

    usr_bin_env New Member

    I just added "local_recipient_maps =" to the postfix config and the message "Recipient address rejected: User unknown in host recipient table" has disappeared. It seems that the email gets sent but i still don't receive it either with gmail and my domain.
     
  4. falko

    falko Super Moderator ISPConfig Developer

  5. usr_bin_env

    usr_bin_env New Member

    Hi falko,

    The my ip is listed in SORBS-DUHL 127.0.0.10 3600 and Spamhaus-ZEN 127.0.0.11 900.

    Thanks
     
  6. falko

    falko Super Moderator ISPConfig Developer

  7. usr_bin_env

    usr_bin_env New Member

    Hi Falko,

    Thanks for the information, sorry i have been busy trying to sort my email configuration out. I have put the email server on my vps and i have got it working. Then after messing with getting it to login as user@domain which works fine but receiving the mail is a bit of a pain. When sending email to [email protected] first the mail log said:

    "(delivery failed to mailbox /vmail/example.com/user: unable to create lock file /vmail/example.com/user.lock: Permission denied)"

    just to get it to disappear i chmod 777 then this appears:

    (delivery failed to mailbox /vmail/example.com/user: cannot open file: Is a directory)

    when postfix/dovecot whoever created i didn't, so its complaining about something that itself did. I can not work it out.

    Thanks
     
  8. usr_bin_env

    usr_bin_env New Member

    now the error has gone back to:

    "(delivery failed to mailbox /vmail/example.com/user: unable to create lock file /vmail/example.com/user.lock: Permission denied)"

    :mad:
     
  9. usr_bin_env

    usr_bin_env New Member

    i have sorted but i thought i could only login with user@domain but i can just use user as the username :confused:
     

Share This Page