Problem running systemctl start php-fpm.service

Discussion in 'Installation/Configuration' started by satimis, Nov 25, 2012.

  1. satimis

    satimis New Member

    Hi all,

    I'm following;
    The Perfect Server - OpenSUSE 12.2 x86_64 (Apache2, Dovecot, ISPConfig 3)
    http://www.howtoforge.com/perfect-server-opensuse-12.2-x86_64-apache2-dovecot-ispconfig-3-p4

    building the server on a VM of KVM

    Host - Fedora 17 64bit
    VM - OpenSuse 12.2 64bit
    KVM

    There is NOT much problem until coming to;

    10.1 PHP-FPM
    ===========
    Next create the system startup links for php-fpm and start it:

    # systemctl enable php-fpm.service
    Code:
    php-fpm.service is not a native service, redirecting to /sbin/chkconfig.
    Executing /sbin/chkconfig php-fpm on
    # systemctl start php-fpm.service
    Code:
    Job failed. See system journal and 'systemctl status' for details.
    
    # tail /var/log/messages
    Code:
    Nov 25 21:46:44 server1 systemd[1]: php-fpm.service: control process exited, code=exited status=7
    Nov 25 21:46:44 server1 systemd[1]: Unit php-fpm.service entered failed state.
    Nov 25 21:57:02 server1 systemd[1]: Reloading.
    Nov 25 21:58:25 server1 php-fpm[11173]: Starting php-fpm[25-Nov-2012 21:58:25] ERROR: failed to open error_log (/usr/var/log/php-fpm.log): No such file or directory (2)
    Nov 25 21:58:25 server1 php-fpm[11173]: [25-Nov-2012 21:58:25] ERROR: failed to post process the configuration
    Nov 25 21:58:25 server1 php-fpm[11173]: [25-Nov-2012 21:58:25] ERROR: FPM initialization failed
    Nov 25 21:58:25 server1 startproc: startproc:  exit status of parent of /usr/sbin/php-fpm: 78
    Nov 25 21:58:25 server1 php-fpm[11173]: ..failed
    Nov 25 21:58:25 server1 systemd[1]: php-fpm.service: control process exited, code=exited status=7
    Nov 25 21:58:25 server1 systemd[1]: Unit php-fpm.service entered failed state
    
    Please help. TIA

    B.R.
    satimis
     
  2. satimis

    satimis New Member

    Problem solved

    I forgot deleting ";" (semi-colon) at the beginning of the line. on /etc/php5/fpm/php-fpm.conf

    Code:
    ;error_log = /var/log/php-fpm.log
    
    server1:~ # systemctl enable php-fpm.service
    Code:
    php-fpm.service is not a native service, redirecting to /sbin/chkconfig.
    Executing /sbin/chkconfig php-fpm on
    
    server1:~ # systemctl start php-fpm.service
    no complaint

    Thanks
     
  3. satimis

    satimis New Member

    Problem solved

    duplicate

    deleted
     

Share This Page