Problem port 25

Discussion in 'Server Operation' started by jessesalazar, Nov 17, 2011.

  1. jessesalazar

    jessesalazar New Member

    I've followed the tutorial perfect server ubuntu 11.04, and everything is working pretty good, But when I send a message or receive from my external account it doesn't work, because my ISP is blocking the port 25, so, I went to no-ip webpage and add an "alternate smtp" and "reflector", now I can receive message using the port 587, but when I setup the to use auth sasl, like no-ip said, sending message doesn't work. here is the setup for smtp:
    Use the following settings:

    Outgoing SMTP Server:
    Port Number: 3325 or 587
    Password: <Set on, see above.
    Defaults to your No-IP account password>

    smtp_sasl_auth_enable = yes
    relayhost = [mail.isp.example]
    # Alternative form:
    # relayhost = [mail.isp.example]:submission
    smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd

    # destination credentials
    [mail.isp.example] username:password
    # Alternative form:
    # [mail.isp.example]:submission username:password

    What else do I need to do?

  2. eko_taas

    eko_taas New Member

    receiving port 25 easy workaround

    I found easy solution for my receiving problem (blocked port 25) from

    to shell (as su)
    Inspired by DydDNS discounts, I took 1y for EmailGateway
    Also I made MX settings on domain DNS
    Now I should find out how to add that to ISPConfig firewall-script (that applies also on reboot...) - anyone with good advice, let me know (I found only quote old howtoforge-posts...)
  3. eko_taas

    eko_taas New Member

  4. eko_taas

    eko_taas New Member

    now I needed smtp-relay as well

    My ISP closed sending port after few trials, so now I added relay as well.

    Got it running w/o pain based on

    I am using one of my (new/extra) ISP-email-accounts just to login to ISP's smtp (as relay i.e normal ports OK).....

    Now now both receiving and sending working like a charm for all server1-accounts :D

Share This Page