Problem Port 25 in Azure, postfix CWP mail, help please!

Discussion in 'Server Operation' started by Ffer San, Mar 8, 2020.

  1. Ffer San

    Ffer San New Member

    Hello, I am new to this forum, I hope I am not breaking any rules, I have seen several posts here about problems with port 25, however I cannot solve my problem:

    1. Azure block the outgoing data flow from port 25 in 2017 due to spam issues.

    2. I have a virtual machine in azure, on it I have Cent Os 7 and on top Centos Web Panel.

    2. CWP in turn uses port 25 by default to send smtp emails and roundcube as well.

    3. I can't get emails to go through another port, I have the ports open in azure, in the cwp firewall and I have tried several settings in /etc/postfix/master.cf

    4. I keep getting errors on port 25 etc! I would like to know if someone went through the same thing and how it was resolved!

    I will greatly appreciate any support!

    postfix...
    # service type private unpriv chroot wakeup maxproc command + args
    # (yes) (yes) (yes) (never) (100)
    # ==========================================================================
    smtp inet n - n - - smtpd
    ##Enable SMTP on port 587 only for authenticated/TLS clients
    submission inet n - n - - smtpd
    -o smtpd_enforce_tls=yes
    -o smtpd_sasl_auth_enable=yes
    -o smtpd_client_restrictions=permit_sasl_authenticated,reject
    #
    ##Enable SMTP on port 465 only for authenticated/SSL clients
    smtps inet n - n - - smtpd
    -o smtpd_tls_wrappermode=yes
    -o smtpd_sasl_auth_enable=yes
    -o smtpd_client_restrictions=permit_sasl_authenticated,reject...



    The mail system...
    Your message could not be delivered for more than 4 hour(s).
    It will be retried until it is 5 day(s) old.

    [email protected] com delivery temporarily suspended: connect to
    alt2.gmail-smtp-in.l.google.com[173.194.77.27]:25: Connection timed out

    ports
    [[email protected] ~]# netstat -an | grep LISTEN
    tcp 0 0 0.0.0.0:25 0.0.0.0:* LISTEN
    tcp 0 0 127.0.0.1:953 0.0.0.0:* LISTEN
    tcp 0 0 127.0.0.1:8891 0.0.0.0:* LISTEN
    tcp 0 0 0.0.0.0:4190 0.0.0.0:* LISTEN
    tcp 0 0 127.0.0.1:2302 0.0.0.0:* LISTEN
    tcp 0 0 0.0.0.0:993 0.0.0.0:* LISTEN
    tcp 0 0 0.0.0.0:2082 0.0.0.0:* LISTEN
    tcp 0 0 0.0.0.0:995 0.0.0.0:* LISTEN
    tcp 0 0 0.0.0.0:2083 0.0.0.0:* LISTEN
    tcp 0 0 0.0.0.0:2086 0.0.0.0:* LISTEN
    tcp 0 0 0.0.0.0:2087 0.0.0.0:* LISTEN
    tcp 0 0 127.0.0.1:10025 0.0.0.0:* LISTEN
    tcp 0 0 0.0.0.0:587 0.0.0.0:* LISTEN
    tcp 0 0 0.0.0.0:110 0.0.0.0:* LISTEN
    tcp 0 0 0.0.0.0:2030 0.0.0.0:* LISTEN
    tcp 0 0 0.0.0.0:143 0.0.0.0:* LISTEN
    tcp 0 0 0.0.0.0:2095 0.0.0.0:* LISTEN
    tcp 0 0 0.0.0.0:2031 0.0.0.0:* LISTEN
    tcp 0 0 0.0.0.0:111 0.0.0.0:* LISTEN
    tcp 0 0 0.0.0.0:2096 0.0.0.0:* LISTEN
    tcp 0 0 0.0.0.0:465 0.0.0.0:* LISTEN
    tcp 0 0 10.0.1.4:53 0.0.0.0:* LISTEN
    tcp 0 0 127.0.0.1:53 0.0.0.0:* LISTEN
    tcp 0 0 0.0.0.0:21 0.0.0.0:* LISTEN
    tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN
    tcp6 0 0 :::25 :::* LISTEN
    tcp6 0 0 ::1:953 :::* LISTEN
    tcp6 0 0 :::443 :::* LISTEN
    tcp6 0 0 :::3306 :::* LISTEN
    tcp6 0 0 :::587 :::* LISTEN
    tcp6 0 0 :::111 :::* LISTEN
    tcp6 0 0 :::80 :::* LISTEN
    tcp6 0 0 :::465 :::* LISTEN
    tcp6 0 0 ::1:53 :::* LISTEN
    tcp6 0 0 :::21 :::* LISTEN
    tcp6 0 0 :::22 :::* LISTEN
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You can't run a mail server on a system that has port 25 blocked. There are two options, the recommended one: a) Ditch azure and go to a cloud hoster which supports hosting of mail servers or b) get another server and use that as mail relay server for your first one or use a mail relay service.
     

Share This Page