Problem on maildir quota

Discussion in 'Installation/Configuration' started by themark, May 3, 2011.

  1. themark

    themark Member

    we have a problem with maildir quota.
    We have ispconfig 3 on Fedora system, and we use maildir as mailbox format.

    With this setup, the quota limit that we put on the configuration of the email address is not used by ispconfig (example: if I have a mailbox with 100MB of quota setup, he can receive more and more email over this quota, without any overquota message warning), and from roundcube, the quota displayed it's "unlimited".

    Someone has the same problem? Can we make adjusmente in order to force ispconfig to read this maildir quota?

    Thank you in advance.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    1) Which ispconfig version do you use?
    2) Which lda and pop3/ imap daemon do you use?
  3. themark

    themark Member

    pop3 daemon -> dovecot
    ispconfig version ->

    thank you!
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    That a very old version. Please update to ispconfig Then change the quota of an account in ispconfig and test that account again a few minutes later.
  5. themark

    themark Member

    Well...actually here we have a multiple server installation (4 server connected) with the same versione (as before)...

    It's possible upgrade the ispconfig of only one of these? If it's possible, there is an how-to that we can follow (or better if exist a script that make possibile the upgrade in safe mode)?
    It's pretty delicate because we are already in production enviroment...

    Thank you
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    You have to upgrade ispconfig on all servers in a cluster.

    Thats not a problem. The ispconfig update is safe when you installed your systems as decsribed in the perfect serup or multiserver guides, I use it on my cluster since and never had a problem. You should always install updates, especially on production systems to keep a safe enviroment.

    Just run the:

    command on all servers. Select the defaults. Just on the master, choose "yes" when you get asked if the permissions in the database shall be reconfigured.

    See ispconfig FAQ for instructions to make a backup of the ispconfig install.
  7. themark

    themark Member

    This is the only part that I can't understand. According with this how-to:

    I don't see anything like you had write before. I don't understand the difference between update a slave server and update a master server.
    Can you give more clear on this specific matter?

    Thank you
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Just run the script:

    on every server. It does not matter if its a slve or master server. The script will ask you several questions during update. One question is if you want to reconfigure the mysql user permissions and there you have to choose "yes" when you are on the master while you accept the default (which is no) on the slaves.
  9. themark

    themark Member

    OK Till, I can confirm that all works very well (THANK YOU)...just two small things...

    1) While update some server we had received the following error:

    Starting full database update.
    ERROR 1146 (42S02) at line 436: Table 'dbispconfig.userpref' doesn't exist
    ERROR 1146 (42S02) at line 437: Table 'dbispconfig.userpref' doesn't exist
    ERROR 1146 (42S02) at line 438: Table 'dbispconfig.userpref' doesn't exist
    ERROR 1146 (42S02) at line 439: Table 'dbispconfig.userpref' doesn't exist

    what does it means?

    2) We have notice that after the update, on the master named configuration file, in automatic the system insert the option:

    allow-transfer: "none";

    for any domain configured there...obviusly with this option enabled the slave server don't get the zone the past version was not in this way...
    In order to workarount this problem (just because we have several, and several domains hosted there and updating any one thought the control panel took long time...) we had simply removed the pattern "<tmpl_var name='options'>" from the "bind_named.conf.local.master" file.'s correct as workaround? Can you confirm that with the last version of ispconfig 3 we need to directly confirm the address ip of the slave name server?

    Thank you in advance.
    Kind Regards
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    1) seems as if you added a table that does not belong to ispconfig in your ispconfig database as ispconfig has no userprefs table. Please be aware that adding additional tables to ispconfig databases in versions < 3.0.3 might cause data loss on updates.

    2) You missed to set the allowed IP address(es) in the zone settings in ispconfig.
  11. chengkinhung

    chengkinhung New Member

    I have the same problem

    update to ISPConfig can not solve this prolem.

    is it because the mail quota do not support in maildir format ?

Share This Page