Problem on building virtual users

Discussion in 'Server Operation' started by satimis, Apr 3, 2007.

  1. satimis

    satimis New Member

    Hi folks,

    CentOS 4.4 amd64 - server

    I follow following howto building "Virtual Users"
    Virtual Users With Postfix, PostfixAdmin, Courier, Mailscanner, ClamAV On CentOS
    http://www.howtoforge.com/virtual_users_postfix_courier_mailscanner_clamav_centos

    I started "screen" recording all typing/keystrokes and output on the Terminal.

    "sudo" sometimes requested for password. root password did not work. Another time it worked without requesting password. I can't understand WHY.

    If root password did not satisfy the request I have to run "su" or "su -" to proceed. After executing commands ran "exit" to exit.

    $ sudo cat /etc/sudoers | tail
    Code:
    # Same thing without a password
    # %wheel        ALL=(ALL)       NOPASSWD: ALL
    
    # Samples
    # %users  ALL=/sbin/mount /cdrom,/sbin/umount /cdrom
    # %users  localhost=/sbin/shutdown -h now
    
    satimis ALL=(ALL) NOPASSWD:ALL
    vmail  ALL=(ALL)  ALL
    
    $ cat /etc/group | grep satimis
    Code:
    wheel:x:10:root,satimis
    satimis:x:500:
    
    On runing; (page 1)
    Code:
    sudo rpmbuild -ta courier-authlib-0.58.tar.bz2 
    
    root password did not work. I have to run;
    Code:
    $ su -
    Password
    # rpmbuild -ta courier-authlib-0.58.tar.bz2 
    
    After compiling;
    cd $HOME/rpm/RPMS/x86_64
    can't find the directory.

    On reading "screenlog.0" it was found;
    Code:
    ......
    Checking for unpackaged file(s): /usr/lib/rpm/check-files /var/tmp/courier-authlib-0.58-1-root
    Wrote: /usr/src/redhat/SRPMS/courier-authlib-0.58-1.src.rpm
    Wrote: /usr/src/redhat/RPMS/x86_64/courier-authlib-0.58-1.x86_64.rpm
    Wrote: /usr/src/redhat/RPMS/x86_64/courier-authlib-devel-0.58-1.x86_64.rpm
    Wrote: /usr/src/redhat/RPMS/x86_64/courier-authlib-userdb-0.58-1.x86_64.rpm
    Wrote: /usr/src/redhat/RPMS/x86_64/courier-authlib-ldap-0.58-1.x86_64.rpm
    Wrote: /usr/src/redhat/RPMS/x86_64/courier-authlib-mysql-0.58-1.x86_64.rpm
    Wrote: /usr/src/redhat/RPMS/x86_64/courier-authlib-pgsql-0.58-1.x86_64.rpm
    Wrote: /usr/src/redhat/RPMS/x86_64/courier-authlib-pipe-0.58-1.x86_64.rpm
    Wrote: /usr/src/redhat/RPMS/x86_64/courier-authlib-debuginfo-0.58-1.x86_64.rpm
    Executing(%clean): /bin/sh -e /var/tmp/rpm-tmp.3436
    + umask 022
    ...
    
    The rpm packagaes were created on "/usr/src/redhat/RPMS/x86_64" NOT on "$HOME/rpm/RPMS/x86_64".

    Pls advise how to fix the problems.

    Create "/usr/src/redhat/RPMS/x86_64" and copy all rpm packages created to this directory?

    TIA


    B.R.
    satimis
     
  2. till

    till Super Moderator

    If you want to follow the howto, you should always switch to the toot user with "su" before you run screen or execute any commands. Some install and compile scripts will fail if you run them with sudo.
     
  3. satimis

    satimis New Member

    Hi till,

    CentOS 4.4 amd64 -server

    Noted with tks,

    Some commands need "su -" to run, e.g. ifconfig. I don't know its reason. I never know which of them until tested.


    B.R.
    satimis
     
  4. satimis

    satimis New Member

    Hi folks,

    I completed the tests on page-1 of;

    http://www.howtoforge.com/virtual_users_postfix_courier_mailscanner_clamav_centos

    Follows are what I discovered;

    1)
    vi /etc/sudoers, add the line to sudoers file as follow;
    vmail ALL=(ALL) NOPASSWD:ALL

    otherwise it would request for password.


    2)
    The command;
    cd $HOME/downloads rpmbuild -ta courier-imap-4.1.1.tar.bz2

    should be as;
    cd $HOME/downloads && rpmbuild -ta courier-imap-4.1.1.tar.bz2

    otherwise it won't compile the package.


    3)
    The command;
    sudo rpm --install courier-imap-4.1.1-1.4.x86_64.rpm

    should be as;
    sudo rpm --install courier-imap-4.1.1-1.x86_64.rpm


    B.R.
    satimis
     

Share This Page