Problem on antispam tag (also if whitelist enabled)

Discussion in 'General' started by themark, Oct 13, 2011.

  1. themark

    themark Member

    Hi guys, strange problem on antispam.

    On amavisd-new I had setup the array:

    @mynetworks = qw( 127.0.0.0/8 [::1] [FE80::]/10 [FEC0::]/10
    10.0.0.0/8 172.16.0.0/12 192.168.0.0/16 XXX.XXX.XXX.XXX);

    with all my internal IP.
    And it's work fine, because on the log server I can see:

    Oct 13 16:47:57 XXX amavis[15104]: (15104-10) Passed CLEAN, MYNETS LOCAL [XXX.XXX.XXX.XXX]

    But...for certain email, I saw the same log of before (it's look Passed CLEAN) but on the mail subject I have however the tag ***SPAM***

    I really can't find who is tagging my mail...
    (I have also tried with @whitelist_sender_maps but no better resutl).

    "Passed CLEAN" tell me that amavis consider the mail clean (no spam) so someone has some idea of who is that is tagging my mail?

    Thank you, as always.
     
  2. till

    till Super Moderator

    It might be that the email has been delivered to your server with ***SPAM*** prepended to the subjec. This happens e.g. when the sender server runs a spamfilter on outgoing email too and this spamfilter tagged the mails and uses a different spam tag level then your server.
     
  3. themark

    themark Member


    I was thought the same think...but same email on different server (without ispconfig) don't have ***SPAM*** on the subject. My opinion it's that the sender prepend the tag, the same email on two different receiver server will get the tag ***SPAM*** on the object...

    It's there a way that also if I have setup @mynetworks on the amavisd-new some on the machine put the tag on the subject (assume that we have used perfect server installation)?

    As always, thank you.
     
  4. till

    till Super Moderator

    Yes. Amavisd has laos a mynetworks setting in its config file were you can define trusred networks.
     
  5. themark

    themark Member


    yes, @mynetworks it's already defined in the amavisd configuration with all my ips (it works fine....looking on the logs). But some email that arrive from these ips...are still tagged as spam...i know that look unbelieveble but this is my problem....
    :confused::confused::confused:
     
  6. till

    till Super Moderator

    Have you tried to set a higher debug / log level in amavisd conf? So that you can see in detail what amavisd is doing and if the tagging is really done by amvisd.
     
  7. themark

    themark Member

    Yes in the middle of all my trying...I have also open the log on debug mode...but it's look all good (and that is not the local amavis tag the mail...neither the sender...)
    In the next days I will try to made other tryout, in the meantime i have partially solved with a workaround made with whitelist.

    Thank you for your support.
    :)
     

Share This Page