Problem logging in (multiserver setup)

Discussion in 'Installation/Configuration' started by Xbennasar, Dec 21, 2018.

  1. Xbennasar

    Xbennasar New Member

    Hi.

    We've been battling this issue for a log time and we don't arrive to a solution.
    Once we setup the servers (Following the perfect server guide) it started working and it was all fine.
    The main server has all the roles except database server and the second has only the database role.

    We've setup some websites, email accounts, ftp... etc. Everything seems to be working by now.

    But, some time ago, we lost the possibility to login to the panel.
    The website asks for credentials, but using the right password doesn't login.

    We've already reset several times the password using the "UPDATE sys_user..." command and it also doesn't work.

    We can login to phpmyadmin and from both servers to the other and local mysql.

    Could you help us trying to find the solution? We need to login to change settings...
    Here you have the results of the script Till asks of both servers:

    WEBSERVER
    -----------------------------------------
    ##### SCRIPT FINISHED #####
    Results can be found in htf_report.txt
    To view results use your favourite text editor or type 'cat htf_report.txt | more' on the server console.

    If you want to see the non-anonymized output start the script with --debug as parameter (php -q htf-common-issues.php --debug).

    [email protected]:~# cat htf_report.txt | more

    ##### SERVER #####
    IP-address (as per hostname): ***.***.***.***
    IP-address(es) (as per ifconfig): ***.***.***.***, ***.***.***.***
    [INFO] ISPConfig is installed.

    ##### ISPCONFIG #####
    ISPConfig version is 3.1.13


    ##### VERSION CHECK #####

    [INFO] php (cli) version is 5.6.33-0+deb8u1
    [INFO] php-cgi (used for cgi php in default vhost!) is version 5.6.33-0+deb8u1

    ##### PORT CHECK #####


    ##### MAIL SERVER CHECK #####


    ##### RUNNING SERVER PROCESSES #####

    [INFO] I found the following web server(s):
    Apache 2 (PID 2440)
    [INFO] I found the following mail server(s):
    Postfix (PID 2906)
    [INFO] I found the following pop3 server(s):
    Dovecot (PID 2583)
    [INFO] I found the following imap server(s):
    Dovecot (PID 2583)
    [INFO] I found the following ftp server(s):
    PureFTP (PID 2758)

    ##### LISTENING PORTS #####
    (only ()
    Local (Address)
    [anywhere]:993 (2583/dovecot)
    [anywhere]:995 (2583/dovecot)
    [localhost]:10024 (2044/amavisd-new)
    [localhost]:10025 (2906/master)
    [localhost]:10026 (2044/amavisd-new)
    [anywhere]:3306 (1909/mysqld)
    [localhost]:10027 (2906/master)
    [anywhere]:587 (2906/master)
    [localhost]:11211 (1306/memcached)
    [anywhere]:110 (2583/dovecot)
    [anywhere]:143 (2583/dovecot)
    [anywhere]:111 (833/rpcbind)
    [anywhere]:465 (2906/master)
    [anywhere]:21 (2758/pure-ftpd)
    ***.***.***.***:53 (1282/named)
    ***.***.***.***:53 (1282/named)
    [localhost]:53 (1282/named)
    [anywhere]:22 (1354/sshd)
    [anywhere]:25 (2906/master)
    [localhost]:953 (1282/named)
    *:*:*:*::*:993 (2583/dovecot)
    *:*:*:*::*:995 (2583/dovecot)
    *:*:*:*::*:10024 (2044/amavisd-new)
    *:*:*:*::*:10026 (2044/amavisd-new)
    *:*:*:*::*:587 (2906/master)
    [localhost]10 (2583/dovecot)
    [localhost]43 (2583/dovecot)
    [localhost]11 (833/rpcbind)
    *:*:*:*::*:8080 (2440/apache2)
    *:*:*:*::*:80 (2440/apache2)
    *:*:*:*::*:465 (2906/master)
    *:*:*:*::*:8081 (2440/apache2)
    *:*:*:*::*:21 (2758/pure-ftpd)
    *:*:*:*::*:53 (1282/named)
    *:*:*:*::*:22 (1354/sshd)
    *:*:*:*::*:25 (2906/master)
    *:*:*:*::*:953 (1282/named)
    *:*:*:*::*:443 (2440/apache2)




    ##### IPTABLES #####
    Chain INPUT (policy ACCEPT)
    target prot opt source destination
    fail2ban-postfix-sasl tcp -- [anywhere]/0 [anywhere]/0
    multiport dports 25
    fail2ban-dovecot-pop3imap tcp -- [anywhere]/0 [anywhere]/0
    multiport dports 110,995,143,993
    fail2ban-pureftpd tcp -- [anywhere]/0 [anywhere]/0 mult
    iport dports 21
    fail2ban-ssh tcp -- [anywhere]/0 [anywhere]/0 multiport
    dports 22

    Chain FORWARD (policy ACCEPT)
    target prot opt source destination

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination

    Chain fail2ban-dovecot-pop3imap (1 references)
    target prot opt source destination
    RETURN all -- [anywhere]/0 [anywhere]/0

    Chain fail2ban-postfix-sasl (1 references)
    target prot opt source destination
    RETURN all -- [anywhere]/0 [anywhere]/0

    Chain fail2ban-pureftpd (1 references)
    target prot opt source destination
    RETURN all -- [anywhere]/0 [anywhere]/0

    Chain fail2ban-ssh (1 references)
    target prot opt source destination
    RETURN all -- [anywhere]/0 [anywhere]/0
    -------------------------------------------------

    DATABASE SERVER
    -------------------------------------------------
    ##### SERVER #####
    IP-address (as per hostname): ***.***.***.***
    IP-address(es) (as per ifconfig): ***.***.***.***, ***.***.***.***
    [INFO] ISPConfig is installed.

    ##### ISPCONFIG #####
    ISPConfig version is 3.1.13


    ##### VERSION CHECK #####

    [INFO] php (cli) version is 5.6.36-0+deb8u1
    [INFO] php-cgi (used for cgi php in default vhost!) is version 5.6.36-0+deb8u1

    ##### PORT CHECK #####

    [WARN] Port 8080 (ISPConfig) seems NOT to be listening
    [WARN] Port 8081 (ISPConfig Apps) seems NOT to be listening
    [WARN] Port 993 (IMAP server SSL) seems NOT to be listening
    [WARN] Port 995 (POP3 server SSL) seems NOT to be listening
    [WARN] Port 465 (SMTP server SSL) seems NOT to be listening
    [WARN] Port 21 (FTP server) seems NOT to be listening

    ##### MAIL SERVER CHECK #####

    [WARN] I found no "submission" entry in your postfix master.cf
    [INFO] this is not critical, but if you want to offer port 587 for smtp connecti
    ons you have to enable this.
    [WARN] I found no "smtps" entry in your postfix master.cf
    [INFO] this is not critical, but if you want to offer SSL for smtp (not TLS) con
    nections you have to enable this.

    ##### RUNNING SERVER PROCESSES #####

    [INFO] I found the following web server(s):
    Apache 2 (PID 1038)
    [INFO] I found the following mail server(s):
    Postfix (PID 3017)
    [INFO] I found the following pop3 server(s):
    Dovecot (PID 2086)
    [INFO] I found the following imap server(s):
    Dovecot (PID 2086)
    [WARN] I could not determine which ftp server is running.

    ##### LISTENING PORTS #####
    (only ()
    Local (Address)
    [localhost]:10024 (991/amavisd-new)
    [anywhere]:3306 (1981/mysqld)
    [localhost]:11211 (1154/memcached)
    [anywhere]:110 (2086/dovecot)
    [anywhere]:143 (2086/dovecot)
    [anywhere]:111 (817/rpcbind)
    [anywhere]:22 (1229/sshd)
    [localhost]:25 (3017/master)
    *:*:*:*::*:10024 (991/amavisd-new)
    [localhost]10 (2086/dovecot)
    [localhost]43 (2086/dovecot)
    [localhost]11 (817/rpcbind)
    *:*:*:*::*:80 (1038/apache2)
    *:*:*:*::*:22 (1229/sshd)
    *:*:*:*::*:25 (3017/master)
    *:*:*:*::*:443 (1038/apache2)




    ##### IPTABLES #####
    Chain INPUT (policy ACCEPT)
    target prot opt source destination

    Chain FORWARD (policy ACCEPT)
    target prot opt source destination

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination

    --------------------------------------


    Thanks in advance!
     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    I do not know what the problem is, but try the previous threads about the problem. Use Internet Search Engines with
    Code:
    login to the panel site:howtoforge.com
    Also, you do not say what operating system you are running on those hosts.
     
  3. Xbennasar

    Xbennasar New Member

    Thanks Taleman.
    I think I've tried everything I've found on Internet...
    OS are both Debian 8 Jessie.

    Hope someone has had the same issue and can point me in the right direction.

    Thanks in advance!
     
  4. Jesse Norell

    Jesse Norell Well-Known Member

    As you don't mention what all you've tried, these may well be redundant, but try clearing your browser cache and maybe run MySQL repair on the dbispconfig tables.
     

Share This Page