Problem installing Quota on the tuto The Perfect Server - Ubuntu 18.04 (Bionic Beaver)

Discussion in 'Installation/Configuration' started by gLeW, Jun 20, 2018.

  1. gLeW

    gLeW New Member

    Hi im following thi tuto to install ispconfig on ubuntu 18.04.

    i have a VPS on DigitalOcea,

    Whe i try to make the Quota step i have this isue.

    My fstab have onlu 2 lines code

    i delete this 2 lines and copy all say in the guide
    if i dont delete the 2 original lines i get an error on the nex step.

    quotacheck -avugm
    givme this error
    quotacheck: Cannot find filesystem to check or filesystem not mounted with quota option.

    when i delete the originakl 2 lines and leave only the tuto lines this step its ok

    but when i put the command
    quotaon -avug
    givme this error
    quotaon: using //quota.group on /dev/vda1 [/]: No such process
    quotaon: Quota format not supported in kernel.
    quotaon: using //quota.user on /dev/vda1 [/]: No such process
    quotaon: Quota format not supported in kernel.


    Thanks
     
  2. Jesse Norell

    Jesse Norell Well-Known Member

  3. gLeW

    gLeW New Member

    Hi Jesse i already see this but still not woprking.
     
  4. nhybgtvfr

    nhybgtvfr Member

    try making the fstab file look like this:

    LABEL=cloudimg-rootfs / ext4 defaults,usrjquota=quota.user,grpjquota=quota.group,jqfmt=vfsv0 0 0
    LABEL=UEFI /boot/efi vfat defaults 0 0
     
  5. gLeW

    gLeW New Member

    Thanks but its the same. same problem.

    Thanks again.
     
  6. nhybgtvfr

    nhybgtvfr Member

    oops. copied the quota part from aws ec2 attempts. try this:

    LABEL=cloudimg-rootfs / ext4 defaults,usrquota,grpquota 0 0
    LABEL=UEFI /boot/efi vfat defaults 0 0

    also, not sure if you've already done this or not, but like aws ec2 instances, the droplets may not have the quota stuff in the kernel by default, you could try this before changing the fstab entries (will need to reboot as well):

    sudo apt-get install linux-image-extra-$(uname -r) linux-image-extra-virtual
     
  7. gLeW

    gLeW New Member

    When i try the sudo say this

    [email protected]:~# sudo apt-get install linux-image-extra-$(uname -r) linux-image-extra-virtual
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Unable to locate package linux-image-extra-4.15.0-23-generic
    E: Couldn't find any package by glob 'linux-image-extra-4.15.0-23-generic'
    E: Couldn't find any package by regex 'linux-image-extra-4.15.0-23-generic'

    its a Digital Ocean VPS
     
  8. nhybgtvfr

    nhybgtvfr Member

    Try this way:
    apt-get remove linux-image-*
    apt-get install linux-image-extra-virtual

    reboot (ideally poweroff, then poweron from the Digital Ocean console)

    modprobe quota_v2
    modprove quota_v1

    then add the quota stuff to fstab and run the quotacheck/quotaon commands.
     
  9. gLeW

    gLeW New Member

    One question, you put
    modprobe quota_v2
    modprove quota_v1
    one time with B and another with V

    and after modprobe add this??

    LABEL=cloudimg-rootfs / ext4 defaults,usrquota,grpquota 0 0
    LABEL=UEFI /boot/efi vfat defaults 0 0
    ????

    Thanks
     
  10. nhybgtvfr

    nhybgtvfr Member

    sorry, that was a typo. both commands should be modprobe

    can try either one of these in /etc/fstab, since DO themselves mention usrquota, i'd try the 1st two lines first.
    LABEL=cloudimg-rootfs / ext4 defaults,usrquota,grpquota 0 0
    LABEL=UEFI /boot/efi vfat defaults 0 0

    LABEL=cloudimg-rootfs / ext4 defaults,usrjquota=quota.user,grpjquota=quota.group,jqfmt=vfsv0 0 0
    LABEL=UEFI /boot/efi vfat defaults 0 0
     
  11. gLeW

    gLeW New Member

    Now work but tellme this

     
  12. nhybgtvfr

    nhybgtvfr Member

    try the second option in fstab then

    not journaled:
    LABEL=cloudimg-rootfs / ext4 defaults,usrquota,grpquota 0 0
    LABEL=UEFI /boot/efi vfat defaults 0 0

    journaled:
    LABEL=cloudimg-rootfs / ext4 defaults,usrjquota=quota.user,grpjquota=quota.group,jqfmt=vfsv0 0 0
    LABEL=UEFI /boot/efi vfat defaults 0 0
     
    gLeW likes this.
  13. gLeW

    gLeW New Member

    Excellent, now working.

    Thanks a lot for your help
     
  14. nhybgtvfr

    nhybgtvfr Member

    cool... now if only it was that easy with 18.04 on aws ec2. can't seem to get quota's working on there at all.
     
  15. gLeW

    gLeW New Member

    lol ... unfortunately I can not help you in that, I do not understand programming, and if it were not for your help I would still be stuck.
    What I do not understand is because it is not in all the same VPS since they are ubuntu.
     

Share This Page