Problem Installing ISPConfig on a Debian System

Discussion in 'Installation/Configuration' started by xyhfna, Feb 3, 2007.

  1. xyhfna

    xyhfna New Member

    I am running Debian 3.1 on an XEN virtual server on a Celeron processor.

    After running through most of the configuration/setup scripts i get the following errors which i am having difficulty understanding. I have had to make a few minor tweaks to the scripts to get it to run (i.e. the path to mysql, which is located as standard at /usr/local/mysql). I have used the apt-get tool to install/update the relevant required programs. Below is the end of the information output to the terminal.

    Please can anyone help/advise?

    /root/ispconfig/openssl/lib/libcrypto.a(cryptlib.o)(.text+0x380): In function `CRYPTO_lock':
    : multiple definition of `CRYPTO_lock'
    /usr/local/mysql/lib/libmysqlclient.a(libtaocrypt_la-misc.o)(.text+0x44): first defined here
    /usr/bin/ld: Warning: size of symbol `CRYPTO_lock' changed from 7 in /usr/local/mysql/lib/libmysqlclient.a(libtaocrypt_la-misc.o) to 378 in /usr/local/mysql/lib/libmysqlclient.a(libtaocrypt_la-misc.o)
    /root/ispconfig/openssl/lib/libcrypto.a(cryptlib.o)(.text+0x7b0): In function `CRYPTO_add_lock':
    : multiple definition of `CRYPTO_add_lock'
    /usr/local/mysql/lib/libmysqlclient.a(libtaocrypt_la-misc.o)(.text+0x4c): first defined here
    /usr/bin/ld: Warning: size of symbol `CRYPTO_add_lock' changed from 7 in /usr/local/mysql/lib/libmysqlclient.a(libtaocrypt_la-misc.o) to 156 in /usr/local/mysql/lib/libmysqlclient.a(libtaocrypt_la-misc.o)
    collect2: ld returned 1 exit status
    make: *** [libphp5.la] Error 1
    ERROR: Could not make PHP

    cd: could not get current directory: getcwd: cannot access parent directories: No such file or directory
    cd: could not get current directory: getcwd: cannot access parent directories: No such file or directory
    job-working-directory: could not get current directory: getcwd: cannot access parent directories: No such file or directory
    mv: cannot stat `binaries/aps.tar.gz': No such file or directory
    mv: cannot stat `binaries/spamassassin.tar.gz': No such file or directory
    job-working-directory: could not get current directory: getcwd: cannot access parent directories: No such file or directory
    mv: cannot stat `binaries/uudeview.tar.gz': No such file or directory
    job-working-directory: could not get current directory: getcwd: cannot access parent directories: No such file or directory
    mv: cannot stat `binaries/clamav.tar.gz': No such file or directory
    job-working-directory: could not get current directory: getcwd: cannot access parent directories: No such file or directory
    mv: cannot stat `binaries/cronolog': No such file or directory
    job-working-directory: could not get current directory: getcwd: cannot access parent directories: No such file or directory
    mv: cannot stat `binaries/cronosplit': No such file or directory
    job-working-directory: could not get current directory: getcwd: cannot access parent directories: No such file or directory
    mv: cannot stat `binaries/ispconfig_tcpserver': No such file or directory
    job-working-directory: could not get current directory: getcwd: cannot access parent directories: No such file or directory
    mv: cannot stat `binaries/zip': No such file or directory
    job-working-directory: could not get current directory: getcwd: cannot access parent directories: No such file or directory
    mv: cannot stat `binaries/unzip': No such file or directory
    job-working-directory: could not get current directory: getcwd: cannot access parent directories: No such file or directory
    job-working-directory: could not get current directory: getcwd: cannot access parent directories: No such file or directory
    tar: spamassassin.tar.gz: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Error exit delayed from previous errors
    mv: cannot stat `spamassassin': No such file or directory
    job-working-directory: could not get current directory: getcwd: cannot access parent directories: No such file or directory
    tar: uudeview.tar.gz: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    job-working-directory: could not get current directory: getcwd: cannot access parent directories: No such file or directory
    tar: Child returned status 2
    tar: Error exit delayed from previous errors
    mv: cannot stat `uudeview': No such file or directory
    job-working-directory: could not get current directory: getcwd: cannot access parent directories: No such file or directory
    job-working-directory: could not get current directory: getcwd: cannot access parent directories: No such file or directory
    tar: clamav.tar.gz: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Error exit delayed from previous errors
    mv: cannot stat `clamav': No such file or directory
    job-working-directory: could not get current directory: getcwd: cannot access parent directories: No such file or directory
    tar: aps.tar.gz: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Error exit delayed from previous errors
    job-working-directory: could not get current directory: getcwd: cannot access parent directories: No such file or directory
    ./setup2: line 860: ispconfig_tmp/php/bin/php: No such file or directory
    job-working-directory: could not get current directory: getcwd: cannot access parent directories: No such file or directory
    ERROR: The PHP binary coming with ISPConfig does not work properly on your system! The installation routine stops here!
    job-working-directory: could not get current directory: getcwd: cannot access parent directories: No such file or directory
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    How much memory do you have in your virtual machine (free RAM and Harddisk=?
     
  3. xyhfna

    xyhfna New Member

    Celeron 1.0 GHz
    RAM 128 MB
    Raid 10 GB

    Freespace: 8.5GB

    no obvious memory errors/overflow, etc.
     
  4. falko

    falko Super Moderator ISPConfig Developer

  5. xyhfna

    xyhfna New Member

    As stated above!

    Filesystem Size Used Avail Use% Mounted on
    /dev/sda1 9.9G 991M 8.5G 11% /
    tmpfs 65M 0 65M 0% /dev/shm

    out of curiosity, why?
    i havent seen anything with regards to memory problems to my recollection.

    As for the install directory i have tried both untarring in / and in /root, then cd to install_ispconf and running the setup script. (The script wont run from outside this dir as it uses local references [./] to chain load other scripts)

    is there an obvious issue i have missed from the output?
     
  6. falko

    falko Super Moderator ISPConfig Developer

  7. Ronin

    Ronin New Member

    I have the excact same problem.

    And I followed the perfect_setup_debian_sarge guide.

    Also made sure that Bison, flex, gcc, zlib, libmysql12-dev, g++, cpp are all installed and up to date.

    I use a 32-bit linux build and have no mem-problems.

    I really have no Idea what to try next :confused:
     
  8. xyhfna

    xyhfna New Member

    I am begining to think sarge is not the best platform for this, is Fedora Core 6 or CentOS 4 likely to be an any better platform for this, was going to get either one reinstalled instead of Debian and retry. I suspect it might have something to do with the fact a lot of packages are moved around or missing in Debian by default and some preinstalled versions are incompatible with ISPconfig.

    Will get my hosting company to reinstall the server and try again.
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Debian stable is one of the best platforms for this and debian has by default much more packages then fedora or centos.

    Maybe your hosting company has messed up the setup by mixing up stable and unstable packages.
     
  10. xyhfna

    xyhfna New Member

    After the last post, i decided NOT to have the sys-admin install anything other than Debian. It already has PHP5.2,MySQL,Apache/Apache2,BIND, and all other dependent packages installed. Followed the instructions again from scratch, litterally line by line incase i 'overlooked' something. Still there is a problem compiling the PHP5.2 binary. Is there anything i might have missed in the terminal output? anything that you might recommend i check? this is REALLY frustrating as i cant see what the 'problem' is. :(
     
  11. Ronin

    Ronin New Member

    Hmmm. There are quite a few topics on this matter on this forums now, but none of the solutions presented in the other topics have worked for me..
    or Xyhf here either it seems..

    I also just tried to start over again with my system, but still the same.. *sigh*
     
  12. xyhfna

    xyhfna New Member

    This is going to sound really stupid, but... I tried an older version of ISPconfig... and it worked first time. I think 2.2.9 may be broken for older servers (i know it evidently shouldnt be!).

    Ronin: U might try doing the same.

    Till: any chance of looking into this? Thanks for trying to help.
     
  13. Ronin

    Ronin New Member

    Oooh.. Hmm.. Gotta try that when I get home today..
     
  14. falko

    falko Super Moderator ISPConfig Developer

    If older ISPConfig versions install fine, but the newest one isn't, I guess the package g++ is missing. This is required by the PHP version in ISPConfig 2.2.9.
    Please try
    Code:
    apt-get install g++
     
  15. xyhfna

    xyhfna New Member

    Sorry, no - g++ already installed!

    apt-get install g++
    Reading package lists... Done
    Building dependency tree... Done
    g++ is already the newest version.

    already checked dependencies and ALL are installed, not sure what is causing the issue with 2.2.9, but the older version works fantastically :)
     
  16. Ronin

    Ronin New Member

    I just tried ISPconfig 2.2.8 and it works like a dream for me too...

    Now I just gotta figure out why my Linux server is crashing my Asus wl500g router all the time *sigh*
     
  17. falko

    falko Super Moderator ISPConfig Developer

    That's really strange... :confused:
     
  18. Ronin

    Ronin New Member

    Indeed it is..
    Gonna try upgrading to 2.2.9 from my 2.2.8 build and see if that works too.
     

Share This Page