Problem installing Canon M4150 on Ubunut.

Discussion in 'Installation/Configuration' started by latvian, Aug 5, 2011.

  1. latvian

    latvian New Member

    Hello everyone,
    I have migrated to Ubunut lately so I am a very newbie and in the learning process. I was trying to setup my printer, Canon MF4150, on Ubuntu 11.04 but was unable to do that. I downloaded the drivers from the Canon website and wind up with 2 .deb files:

    cndrvcups-common_2.20-1_i386.deb
    cndrvcups-ufr2-us_2.20-1_i386.deb

    I started by installing the first file but got the following:

    Code:
    Unpacking cndrvcups-common (from cndrvcups-common_2.20-1_i386.deb) ...
    dpkg: dependency problems prevent configuration of cndrvcups-common:
     cndrvcups-common depends on gs-esp; however:
      Package gs-esp is not installed.
    dpkg: error processing cndrvcups-common (--install):
     dependency problems - leaving unconfigured
    Errors were encountered while processing:
     cndrvcups-common
    
    So what could be the problem is and how to solve it?

    Thanks in advance
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Run
    Code:
    apt-get install gs-esp
    and try again.
     
  3. latvian

    latvian New Member

    Thanks for your reply. I ran the command and got the following:

    Code:
    sudo apt-get install gs-esp
    [sudo] password for : 
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Package gs-esp is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source
    
    E: Package 'gs-esp' has no installation candidate
    
    Any suggestions would be appreciated.
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Try this instead:
    Code:
    sudo apt-get install ghostscript-x
     
  5. latvian

    latvian New Member

    I got the following message:

    Code:
    The following packages have unmet dependencies:
     cndrvcups-common : : gs-esp 
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Can you run
    Code:
    sudo apt-get update
    and try again?
    If it doesn't work, can you post the full output of
    Code:
    sudo apt-get install ghostscript-x
    ?
     
  7. latvian

    latvian New Member

    Code:
    [email protected]:~$ sudo apt-get install ghostscript-x
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    ghostscript-x is already the newest version.
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    
     
  8. falko

    falko Super Moderator ISPConfig Developer

    The problem is that gs-esp was available as a package up to Ubuntu 10.10, but not for 11.04 (see http://packages.ubuntu.com/search?keywords=gs-esp ). It has been replaced with ghostscript-x, but apparently your Canon packages insist on gs-esp being installed.

    Can you try to install them like this?
    Code:
    dpkg -i --ignore-depends=gs-esp [I]package_name[/I]
     
  9. latvian

    latvian New Member

    I tried the above command but it didnt work... :(
     
  10. falko

    falko Super Moderator ISPConfig Developer

    Any error messages?
     
  11. sreedhar2u

    sreedhar2u New Member

    I too have the same issue. falko comments helped me to resolve my drivers installation issue.


    sudo dpkg -i --ignore-depends=gs-esp cndrvcups-common_2.20-1_i386.deb


    sudo dpkg -i cndrvcups-ufr2-uk_2.20-1_i386.deb
     
  12. mbat298

    mbat298 New Member

    Suggestion

    Hi,

    I just installed a driver for a Canon MF8300 series with a method like this. But I discovered a pretty serious problem afterwards...

    apt-get is broken because it still thinks I need gs-esp, even though I installed ghostscript-x. Yes, the printer driver works. But apt-get doesn't want to do any upgrades or install other software.

    To fix the problem, I followed the advice in the following thread:

    http://lists.debian.org/debian-printing/2011/03/msg00048.html

    The thread suggests a work-around using equivs to create a fake gs-esp package to fool apt-get.

    I'm suggesting this solution if you face this problem. However, it took me a bit of trial and error before I got it fixed, so I can't guarantee that this work for certain...

    Before you can install equivs with apt-get, you'll need to fix apt-get. (Note: this will probably ask you to remove the printer drivers you just installed, so you'll have to reinstall afterwards).

    Code:
    sudo apt-get -f install
    Once, apt get is fixed, install equivs.
    Code:
    sudo apt-get install equivs
    Then use equivs to create a fake gs-esp package. Use gedit (or substitute your favorite text editor) to create a file called fake-gs-esp.control
    Code:
    gedit fake-gs-esp.control
    Inside this file place the following two lines, followed by enter:
    Code:
    Package: fake-gs-esp
    Provides: gs-esp
    
    Then, build the package and install the fake-gs-esp
    Code:
    equivs-build fake-gs-esp.control
    sudo dpkg -i fake-gs-esp_1.0_all.deb
    
    Afterwards, reinstall the printer driver using the methods described in this thread.
     

Share This Page