problem in upgrading from debian 8 to 9

Discussion in 'ISPConfig 3 Priority Support' started by tritema, Nov 6, 2020.

Tags:
  1. tritema

    tritema Member HowtoForge Supporter

    i started from perfect server debian 7.6 and then upgraded successfully to deb 8.1. Now i am trying to upgrade to debian 9 following your
    https://www.howtoforge.com/tutorial/how-to-upgrade-debian-8-jessie-to-9-stretch/
    all goes smoothly until during dist-upgrade i get this error:
    Errors were encountered while processing:
    mariadb-server-10.1
    default-mysql-server
    mysql-server
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    i tryied to use flag -f to resolve, but still in this error.
    any ideas?
     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Do the upgrade following Debian upgrade instructions, they are in the release notes. You might need to follow first the release notes for Debian 8 to make sure that upgrade is completed successfully.
    https://www.debian.org/releases/jessie/releasenotes
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Most likely there are some settings in the mariadb config files that are not supported anymore by the new version. Check mysql logs and syslogs for further error messages.
     
  4. tritema

    tritema Member HowtoForge Supporter

    yes i did the check and the upgrade to 8.1 is completed successfully and works fine. the problem is going to the 9, when dealing with the change from mysql to mariadb
     
  5. Taleman

    Taleman Well-Known Member HowtoForge Supporter

Share This Page