Problem in Proftpd configuration

Discussion in 'Installation/Configuration' started by tecnico001, Mar 5, 2007.

  1. tecnico001

    tecnico001 New Member

    I have a problem in Proftpd configuration. I istalled Proftpd according to the Perfect Setup on FC5.

    the FPT work perfect Into the ISPconfig panel, but with a client (filezilla) show 530 Login incorrect.

    and the ssh access with the user for ISPconfig either work.

    My SO is Openvz-FC5


    The proftpd is running and proftpd.conf is:

    ServerName "ProFTPD server"
    ServerIdent on "FTP Server ready."
    ServerAdmin root@localhost
    ServerType standalone
    DefaultServer on
    AccessGrantMsg "User %u logged in."
    DeferWelcome off
    DefaultRoot ~ !adm
    AuthPAMConfig proftpd
    AuthOrder mod_auth_pam.c* mod_auth_unix.c
    IdentLookups off
    UseReverseDNS off
    Port 21
    Umask 022
    ListOptions "-a"
    AllowRetrieveRestart on
    AllowStoreRestart on
    MaxInstances 20
    User nobody
    Group nobody
    UseSendfile no
    ScoreboardFile /var/run/proftpd.score
    <Global>
    AllowOverwrite yes
    <Limit ALL SITE_CHMOD>
    AllowAll
    </Limit>
    </Global>
    LogFormat default "%h %l %u %t \"%r\" %s %b"
    LogFormat auth "%v [%P] %h %t \"%r\" %s"
    DefaultRoot ~
    Include /etc/proftpd_ispconfig.conf


    do you have any a clue?
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Please post the output of:

    iptables -L

    and:

    netstat -tap
     
  3. tecnico001

    tecnico001 New Member

    This is the information:

    iptables:

    Chain INPUT (policy ACCEPT)
    target prot opt source destination

    Chain FORWARD (policy ACCEPT)
    target prot opt source destination

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination


    netstat:
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 *:imaps *:* LISTEN 32600/dovecot
    tcp 0 0 *:pop3s *:* LISTEN 32600/dovecot
    tcp 0 0 *:mysql *:* LISTEN 32578/mysqld
    tcp 0 0 *:pop3 *:* LISTEN 32600/dovecot
    tcp 0 0 *:imap *:* LISTEN 32600/dovecot
    tcp 0 0 *:http *:* LISTEN 1422/httpd
    tcp 0 0 *:hosts2-ns *:* LISTEN 1400/ispconfig_http
    tcp 0 0 *:ftp *:* LISTEN 6046/proftpd: (acce
    tcp 0 0 altairxxx.dnsprincip:domain *:* LISTEN 1533/named
    tcp 0 0 *:ssh *:* LISTEN 32473/sshd
    tcp 0 0 altairxxx.dnsprincipal:rndc *:* LISTEN 1533/named
    tcp 0 0 *:smtp *:* LISTEN 1492/master


    I believe this is a configuration error.
     
  4. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Did you provide the same username and password with filezilla? Have you tried active and passive FTP mode?
     

Share This Page