problem in interface for users

Discussion in 'Installation/Configuration' started by jmroth, Sep 17, 2005.

  1. jmroth

    jmroth ISPConfig Developer ISPConfig Developer

    If I login as a site administrator/user, then click on the site on the left panel, then goto User&Email, it will display "Unlimited" in the Webspace MB field. If I try to switch tabs it complains that "Umlimited" is not a number (it complains in German, even if the language is set to English).
    Also, if the user I have logged in as is the Administrator of the site itself), it will no longer be after I exit and look at the user again as the ISPConfig admin. All flags like Spamfilter, Antivirus, Catchall, Mailscan have also been reset. :-(
    Last but not least: Can I configure the language in which the interface is displayed to the user in some other way except logging in as the user and selecting another language. Is there a default setting somewhere (I'd prefer English)?

    Goodie: (Bug: see attached picture)
    I called the hostname "mx" and it displayed this

    Attached Files:

  2. falko

    falko Super Moderator ISPConfig Developer

    This will be fixed in the next release. For now, simply uncomment the lines 652 - 656 in /home/admispconfig/ispconfig/web/isp_kunde/edit/edit.php. That's the following block:

    if($value == '-1'$value $go_api->lng("Unbegrenzt");
    $element_val->name != 'web_mysql_anzahl_dbs' && $element_val->name != 'web_anonftplimit' && $element_val->name != 'server_id' && $element_val->name != 'web_speicher' && $element_val->name != 'web_traffic' && $element_val->name != 'web_userlimit' && $element_val->name != 'web_domainlimit' && $element_val->name != 'web_traffic_ueberschreitung' && $element_val->name != 'web_traffic_status'){
    $value == '0'$value '<font color="#FF0000"><b>'.$go_api->lng("Nein").'</b></font>';
    $value == '1'$value '<font color="#009F00"><b>'.$go_api->lng("Ja").'</b></font>';

Share This Page