problem in accentuation with uebimiau

Discussion in 'Installation/Configuration' started by lunardi, Mar 31, 2007.

  1. lunardi

    lunardi New Member

    Hi all,

    All messages open in uebimiau to be published problem in accentuation.

    Example:

    explicação ---> explicaão
    atualização ---> atualizaão
    manipulação ---> manipulaão

    Please, help me.

    Thanks
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Do you have the correct locales installed on your server?
     
  3. lunardi

    lunardi New Member

    Hi,

    from uebimiau ?

    Attention:
    The accentuation in site is OK, just in messages open in uebimiau.

    Thanks
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Which distribution do you use?
     
  5. lunardi

    lunardi New Member

    Hi,

    I´m use Ubuntu (kernel 2.6.15) and ISPConfig 2.2.10

    Thanks
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Please run
    Code:
    dpkg-reconfigure locales
    and select all locales you need.
     
  7. lunardi

    lunardi New Member

    Hi,

    I´m execute the command "dpkg-reconfigure locales" and return:

    [email protected]:/home/usuario# dpkg-reconfigure locales
    Generating locales...
    en_US.UTF-8... up-to-date
    pt_BR.UTF-8... up-to-date
    Generation complete.
    Current default timezone: 'America/Sao_Paulo'.
    Local time is now: Seg Abr 2 10:34:28 BRT 2007.
    Universal Time is now: Seg Abr 2 13:34:28 UTC 2007.
    Run 'tzconfig' if you wish to change it.
    [email protected]:/home/usuario#

    After reload in apache2, but the problem continue, to see new e-mail open in uebimiau:

    autenticação ---> autenticaão
    procuração ---> procuraão
    atenção ---> atenão

    Thanks
     
  8. falko

    falko Super Moderator ISPConfig Developer

    Please take a look at the HTML source code of such a page in Uebimiau. Is there a charset specified between <head> and </head>?
     
  9. lunardi

    lunardi New Member

    Hi Falko,

    I´m search in all files of uebimiau in /home/admispconfig/ispconfig/web/webmail/ , but not to find.

    And search in code page HTML of uebimiau, but not to find "charset".

    Any ideia ?

    Thanks
     
  10. falko

    falko Super Moderator ISPConfig Developer

    I don't mean the files on your server, I mean in your browser you should take a look at the source code of the Uebimiau pages.
     
  11. lunardi

    lunardi New Member

  12. lunardi

    lunardi New Member

    Hi all,

    Please, help me.

    Thanks.
     
  13. falko

    falko Super Moderator ISPConfig Developer

    All I want you to do is open Uebimiau in a browser, then right-click and select "View page source". Then check if the charset is set in the sources.
     
  14. lunardi

    lunardi New Member

    Hi Falko,

    Just in file /webmail/index.php to find "charset" and:
    charset=iso-8859-1

    And now ?

    Thanks again.
     
  15. till

    till Super Moderator Staff Member ISPConfig Developer

    Now you will have to look at the uebimiau source files to find out where the charset is set and chnage it to a charset that supports your special chars.
     
  16. lunardi

    lunardi New Member

    Hi,

    The charset=iso-8859-1 in uebimiau equal in apache.
    I'm NOT to solve.

    Thanks again.
     
  17. zanard

    zanard New Member

    You are able to change uebimiau charset in language file in webmail/langs directory, in language file you must find lines as described below:

    ..

    date_format = %d/%m/%y %H:%M

    # CharSet
    default_char_set = iso-8859-1


    # Menu

    ..

    Change charset and that all!
     
  18. lunardi

    lunardi New Member

    Hi Zanard,

    In file pt_BR.txt the option "default_char_set" its:

    default_char_set = iso-8859-1

    The problem continue:
    procuração -> procurao

    Thanks again
     
  19. zanard

    zanard New Member

    Change charset to utf-8

    Change charset to utf-8 and check results!
     
  20. lunardi

    lunardi New Member

    Hi Zanard,


    I´m change in file pc_BR.txt the option "default_char_set" to "utf-8" and reload apache2, but the problem continue.

    Thanks again
     

Share This Page