problem implementing wildcard SSL

Discussion in 'Installation/Configuration' started by abubin, Jul 3, 2013.

  1. abubin

    abubin New Member

    i am having problem getting wildcard SSL to work in ispconfig.

    I have followed some guide in this forum on implementing pre-configured SSL but it still doesn't work.

    Getting error
    Secure Connection Failed
              An error occurred during a connection to
    SSL received a record that exceeded the maximum permissible length.
    (Error code: ssl_error_rx_record_too_long)
    I even tried to manually configure the SSL but it doesn't work.

    I am using ubuntu 10.04LTS.

    I have ispconfig gui running in self-created SSL cert. Could this be the reason for the problem? Perhaps I should disable SSL in ispconfig gui and then try to configure the website again to use SSL?

    Would really appreciate help from the pros here.

    more errors from apache logs:
    Last edited: Jul 3, 2013
  2. abubin

    abubin New Member

    no solution for this?
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    The ssl key is not matching the ssl cert. If you install a ssl cert were the csr was created outside of ispconfig, you will have to replace the ssl key generated by ispconfig with the ssl key that you created outside of ispconfig for this certificate.

Share This Page