problem HTACCES in VQadmin

Discussion in 'Server Operation' started by scherpenzeel, Nov 29, 2006.

  1. scherpenzeel

    scherpenzeel New Member

    Hi I have installed qmail and vqadmin. Installation work fine until the last time I tried to get in VQadmin. I can log in thats no problem. But then when I want to create a new e-mail account or get an overview of the domains I get this message:

    Authenticatie: Username unknown
    This will not work. You need to have htacces in place. or the cgi script will not work.

    Now I checked and I have an HTACCES its working otherwise I can not log in?
    So whats wrong here. Please give me some support on this. Since I need to create some new e-mail accounts fast.

    This is some additional info:

    dit is de instelling:
    hopla:~# ls -la /var/www/my.dedicated.com/cgi-bin/vqadmin/
    total 116
    drwxr-xr-x 3 hopla vchkpw 4096 2006-09-14 14:47 .
    drwxr-xr-x 3 hopla hopla 4096 2006-09-14 14:48 ..
    -rw-r--r-- 1 admin hopla 162 2006-09-14 14:47 .htaccess
    drwxr-xr-x 2 hopla vchkpw 4096 2006-05-15 23:27 html
    -rw-r--r-- 1 hopla vchkpw 864 2006-05-01 11:02 vqadmin.acl
    -rwxr-xr-x 1 hopla root 93820 2006-05-15 23:27 vqadmin.cgi


    The .htaccess file i use.

    AuthType Basic
    AuthName "Verboden Toegang!"
    AuthUserFile /etc/apache2/passwords//.htpasswd
    AuthGroupFile /dev/null
    <Limit GET>
    require user admin
    </Limit>

    So I can log in, but then I get the message:

    "Authentication Failed Username unknown

    vQadmin was unable to determine your username, which
    means your webserver is improperly configured to run
    with this CGI. For security reasons, this script
    will not run without Apache htaccess lists.

    Now this is what I have in the cgi script:
    Access List Definitions
    # [email protected]
    #
    #
    # Default group contains permissions for all users
    # not listed under any groups
    #
    # If the default group is not defined, users not
    # listed under any other groups will have no
    # permissions.
    #
    # Examples follow...
    #
    admin - VIMUCADX
    default - VI
    #
    # Access permissions:
    #
    # V View user information
    # I View domain information
    # M Modify user information
    # U Modify domain information
    # C Create user
    # A Create domain
    # D Delete user
    # X Delete domain
    #
    # These features will still appear in the HTML templates
    # if the user doesn't have access to them, however, they will
    # get a permission denied error if they try to make use of
    # them.
    #
    #tech VI tech1user
    admin VIMUDCAX admin1user
    #hopla VIMUDCAX adminhopla
    hopla * admin
    #
    # An asterisk in the features field specifies that you
    # want all users in this group to have access to
    # all features.


    So what's wrng here..
     
    Last edited: Nov 29, 2006
  2. falko

    falko Super Moderator ISPConfig Developer

    What's your Apache vhost configuration for that vhost?
     
  3. scherpenzeel

    scherpenzeel New Member

    this is what i have in my apache config:
    ~ /etc/apache2/sites-enabled/000-default:

    Code:
    NameVirtualHost *
    <VirtualHost *>
            ServerAdmin [email protected]
    
            DocumentRoot /var/www/
            <Directory />
                    Options FollowSymLinks
                    AllowOverride all
            </Directory>
            <Directory /var/www/>
                    Options Indexes FollowSymLinks MultiViews
                    AllowOverride all
                    Order allow,deny
                    allow from all
                    # This directive allows us to have apache2's default start page
                    # in /apache2-default/, but still have / go to the right place
                    #RedirectMatch ^/$ /apache2-default/
            </Directory>
    
            ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
            <Directory "/usr/lib/cgi-bin/vqadmin">
                    AllowOverride all
                    Options ExecCGI -MultiViews +SymLinksIfOwnerMatch
                    Order allow,deny
                    Allow from all
            </Directory>
    
    #       ScriptAlias /cgi-bin/ /var/www/my.dedicated.server.nl/cgi-bin/
    #       <Directory "/var/www/my.dedicated.server.nl/cgi-bin/">
    #               allow from all
    #               Options +ExecCGI  -MultiViews +SymLinksIfOwnerMatch
    #               AddHandler cgi-script .cgi .pl
    #               AllowOverride All
    #               Order deny,allow
    #       </Directory>
    
            ErrorLog /var/log/apache2/error.log
    
            # Possible values include: debug, info, notice, warn, error, crit,
            # alert, emerg.
            LogLevel warn
    
            CustomLog /var/log/apache2/access.log combined
            ServerSignature On
    
        Alias /doc/ "/usr/share/doc/"
        <Directory "/usr/share/doc/">
            Options Indexes MultiViews FollowSymLinks
            AllowOverride all
            Order deny,allow
            Deny from all
            Allow from ...
        </Directory>
    
    Alias /phpMyadmin/ "/var/www/phpMyadmin/"
    
    <Directory "/var/www/phpMyadmin/">
    Options MultiViews
    AllowOverride all
    Order allow,deny
    Allow from all
    </Directory>
    
    </VirtualHost>
    NameVirtualHost *:80
    
    # VirtualHost example:
    # Almost any Apache directive may go into a VirtualHost container.
    
    
    <VirtualHost _default_:*>
    </VirtualHost>
    
    #--- hier de basis pagina van de This is for the dns i have, without a site, server waar je op komt als er geen site is maar wel een domeinnaam -----
    
    <VirtualHost *:80>
    DocumentRoot "/var/www/my.dedicated.server.nl"
    ServerName my.dedicated.server.nl
    ServerAlias my.dedicated.server.nl
    <Directory "/var/www/my.dedicated.server.nl">
    Options -Indexes
    </Directory>
    ScriptAlias /cgi-bin/ /var/www/my.dedicated.server.nl/cgi-bin/
    AddHandler cgi-script .cgi .pl
    <Directory "/var/www/my.dedicated.server.nl/cgi-bin/">
    allow from all
    Options +ExecCGI  -MultiViews +SymLinksIfOwnerMatch
    AllowOverride All
    Order deny,allow
    </Directory>
    </VirtualHost>
    
    #from here the virtual hosts for all the sites on the server -----
    after creating the htaccess and htpass:
    I have done this:
    chown admin /var/www/my.dedicated.server.nl/cgi-bin/vqadmin/.htaccess
    and also
    ~# chmod 644 /var/www/my.dedicated.server.nl/cgi-bin/vqadmin/.htaccess

    this is in the vqadmin.acl file:
    # permissions.
    #
    # Examples follow...
    #
    admin - VIMUCADX
    default - VI
    #
    # Access permissions:
    #
    # V View user information
    # I View domain information
    # M Modify user information
    # U Modify domain information
    # C Create user
    # A Create domain
    # D Delete user
    # X Delete domain
    #
    # These features will still appear in the HTML templates
    # if the user doesn't have access to them, however, they will
    # get a permission denied error if they try to make use of
    # them.
    #
    #tech VI tech1user
    admin VIMUDCAX admin1user

    #
    # An asterisk in the features field specifies that you
    # want all users in this group to have access to
    # all features.
    #
    senior * admin


    this is in the htacces:

    AuthType Basic
    AuthName "Verboden Toegang!"
    AuthUserFile /etc/apache2/passwords//.htpasswd
    AuthGroupFile /dev/null
    <Limit GET>
    require user admin
    </Limit>

    and the /etc/apache2/passwords//.htpasswd is also there.

    , I can log in into vqadmin but can not do, or see, or add, or change anything.
     
    Last edited: Dec 2, 2006
  4. falko

    falko Super Moderator ISPConfig Developer

    Can you disable the <VirtualHost *>...</VirtualHost> and just use this one?

    Code:
    <VirtualHost *:80>
    DocumentRoot "/var/www/my.dedicated.server.nl"
    ServerName my.dedicated.server.nl
    ServerAlias my.dedicated.server.nl
    <Directory "/var/www/my.dedicated.server.nl">
    Options -Indexes
    </Directory>
    ScriptAlias /cgi-bin/ /var/www/my.dedicated.server.nl/cgi-bin/
    AddHandler cgi-script .cgi .pl
    <Directory "/var/www/my.dedicated.server.nl/cgi-bin/">
    allow from all
    Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
    AllowOverride All
    Order deny,allow
    </Directory>
    </VirtualHost>
     
  5. scherpenzeel

    scherpenzeel New Member

    I do not realy understand what you mean? Which part from the above do need to leave out? Since I have several sites in the /var/www/ dir.
    If I leave the part above <VirtualHost *:80> ... </VirtualHost> out i Think it will give me even bigger problems?

    After this part I have all my VirtualHosts for the different sites I serve.

    Code:
    #from here the virtual hosts for all the sites on the server -----
    <VirtualHost *:80>
    DocumentRoot "/var/www/fakelog.nl"
    ServerName www.fakelog.nl
    ServerAlias fakelog.nl
    <Directory "/var/www/fakelog.nl">
    Options Indexes
    </Directory>
    </VirtualHost>
    So what can I leave out and what should remain? :confused:
     
  6. falko

    falko Super Moderator ISPConfig Developer

    The part above
    Code:
    #--- hier de basis pagina van de This is for the dns i have, without a site, server waar je op komt als er geen site is maar wel een domeinnaam -----
     
  7. scherpenzeel

    scherpenzeel New Member

    I can log in into vqadmin but than it the same again... :confused:

    I get this message when restarting:

    Code:
    :~# /etc/init.d/apache2 restart
    Forcing reload of web server: Apache2[Sun Dec 03 20:12:39 2006] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
    [Sun Dec 03 20:12:39 2006] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
    [Sun Dec 03 20:12:39 2006] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
    [Sun Dec 03 20:12:39 2006] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
    [Sun Dec 03 20:12:39 2006] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
    [Sun Dec 03 20:12:39 2006] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
    [Sun Dec 03 20:12:39 2006] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
    [Sun Dec 03 20:12:39 2006] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
    [Sun Dec 03 20:12:40 2006] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
    [Sun Dec 03 20:12:40 2006] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
    [Sun Dec 03 20:12:40 2006] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
    [Sun Dec 03 20:12:40 2006] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
    [Sun Dec 03 20:12:40 2006] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
    [Sun Dec 03 20:12:40 2006] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
    [Sun Dec 03 20:12:40 2006] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
    [Sun Dec 03 20:12:40 2006] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
    .
    this is what i have left in my config:

    Code:
    <VirtualHost *:80>
    DocumentRoot "/var/www/my.dedicated.server.nl"
    ServerName my.dedicated.server.nl
    ServerAlias my.dedicated.server.nl
    <Directory "/var/www/my.dedicated.server.nl">
    Options -Indexes
    </Directory>
    ScriptAlias /cgi-bin/ /var/www/my.dedicated.server.nl/cgi-bin/
    AddHandler cgi-script .cgi .pl
    <Directory "/var/www/my.dedicated.server.nl/cgi-bin/">
    allow from all
    Options +ExecCGI  -MultiViews +SymLinksIfOwnerMatch
    AllowOverride All
    Order deny,allow
    </Directory>
    </VirtualHost>
    
    
    
    
    #from here the virtual hosts for the sites.vanaf hier de virtual hosts neerzetten die op de server staan -----
    
    <VirtualHost *:80>
    DocumentRoot "/var/www/fakelog.nl"
    ServerName www.fakelog.nl
    ServerAlias fakelog.nl
    <Directory "/var/www/fakelog.nl">
    Options -Indexes
    </Directory>
    </VirtualHost>
    
    <VirtualHost *:80>
    DocumentRoot "/var/www/www.bestlog.nl"
    ServerName www.bestlog.nl
    ServerAlias bestlog.nl
    <Directory "/var/www/www.bestlog.nl">
    Options -Indexes
    </Directory>
    </VirtualHost>
    
    
    etc.
    Now I can not acces the other sites anymore they arre all forewarded to the /var/www/www.mydedicated.server.nl
     
  8. scherpenzeel

    scherpenzeel New Member

  9. falko

    falko Super Moderator ISPConfig Developer

    Please replace all <VirtualHost *:80> with <VirtualHost 1.2.3.4:80> where 1.2.3.4 is your IP address.
     
  10. scherpenzeel

    scherpenzeel New Member

    I am sorry but that does not work. It gives a lot of error messages when restarting apache.

    Is it possible re/installing VQadmin again, or do I than have to install the complete q-mail pakcage again?
    If yes how should i do that best ..apt-get remove? or just remove the files manualy and reinstall them?

    I am completely lost here.
     
  11. falko

    falko Super Moderator ISPConfig Developer

    What are the exact error messages?
     
  12. scherpenzeel

    scherpenzeel New Member

    Hi since I restored my previous config I had to try the changes you mentioned again. This time i did not get any fault messages. And I am still able to visit all the sites.
    But the problem with Vqadmin still remains the same???

    this is in the errorlog:
    Code:
    [Wed Dec 06 12:56:12 2006] [error] [client 83.120.50.131] File does not exist: /var/www/my.dedicated.server.nl/imag$
    [Wed Dec 06 12:56:14 2006] [error] [client 83.120.50.131] File does not exist: /var/www/my.dedicated.server.nl/imag$
    [Wed Dec 06 12:59:58 2006] [error] [client 74.6.74.227] File does not exist: /var/www/www.nitalie.nl/robots.txt
    [Wed Dec 06 13:01:08 2006] [notice] caught SIGTERM, shutting down
    [Wed Dec 06 13:01:09 2006] [notice] Apache/2.0.54 (Debian GNU/Linux) PHP/4.3.10-16 mod_ssl/2.0.54 OpenSSL/0.9.7e mod_perl/1.$
    [Wed Dec 06 13:01:17 2006] [error] [client 83.120.50.131] File does not exist: /var/www/my.dedicated.server.nl/imag$
    [Wed Dec 06 13:01:24 2006] [error] [client 83.120.50.131] File does not exist: /var/www/my.dedicated.server.nl/imag$
    
    [Wed Dec 06 13:02:00 2006] [error] [client 83.120.50.131] File does not exist: /var/www/my.dedicated.server.nl/imag$
    $l/images/vqadmin, referer: http://212.211.9.72/cgi-bin/vqadmin/vqadmin.cgi/show/show_domains.html
    
    [Wed Dec 06 13:02:41 2006] [error] [client 86.87.107.117] File does not exist: /var/www/www.pizzajo.nl/inhoud, referer: h$
    [Wed Dec 06 13:02:42 2006] [error] [client 86.87.107.117] File does not exist: /var/www/www.pizzajo.nl/inhoud, referer: h$
    This is what I have in my config now:
    Code:
    NameVirtualHost *
    <VirtualHost *>
            ServerAdmin [email protected]
    
            DocumentRoot /var/www/
            <Directory />
                    Options FollowSymLinks
                    AllowOverride all
            </Directory>
            <Directory /var/www/>
                    Options Indexes FollowSymLinks MultiViews
                    AllowOverride all
                    Order allow,deny
                    allow from all
                    # This directive allows us to have apache2's default start page
                   # in /apache2-default/, but still have / go to the right place
                    #RedirectMatch ^/$ /apache2-default/
            </Directory>
    
    #       ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
    #       <Directory "/usr/lib/cgi-bin/vqadmin">
    #               AllowOverride all
    #               Options ExecCGI -MultiViews +SymLinksIfOwnerMatch
    #               Order allow,deny
    #               Allow from all
    #       </Directory>
    
    #       ScriptAlias /cgi-bin/ /var/www/my.dedicated.server.nl/cgi-bin/
    #       <Directory "/var/www/my.dedicated.server.nl/cgi-bin/">
    #               allow from all
    #               Options +ExecCGI  -MultiViews +SymLinksIfOwnerMatch
    #               AddHandler cgi-script .cgi .pl
    #               AllowOverride All
    #               Order deny,allow
    #       </Directory>
    
            ErrorLog /var/log/apache2/error.log
    
            ErrorLog /var/log/apache2/error.log
    
            # Possible values include: debug, info, notice, warn, error, crit,
            # alert, emerg.
            LogLevel warn
    
            CustomLog /var/log/apache2/access.log combined
            ServerSignature On
    
        Alias /doc/ "/usr/share/doc/"
        <Directory "/usr/share/doc/">
            Options Indexes MultiViews FollowSymLinks
            AllowOverride all
            Order deny,allow
            Deny from all
            Allow from 127.0.0.0/255.0.0.0 ::1/128
        </Directory>
    
    Alias /phpMyadmin/ "/var/www/phpMyadmin/"
    
    <Directory "/var/www/phpMyadmin/">
    Options MultiViews
    AllowOverride all
    Order allow,deny
    Allow from all
    </Directory>
    
    </VirtualHost>
    NameVirtualHost 212.211.9.72:80
    
    # VirtualHost example:
    # Almost any Apache directive may go into a VirtualHost container.
    
    <VirtualHost _default_:*>
    </VirtualHost>
    
    #--- hier de basis pagina van de server waar je op komt als er geen site is maar wel een domeinnaam -----
    
    <VirtualHost 212.211.9.72:80>
    DocumentRoot "/var/www/my.dedicated.server.nl"
    ServerName my.dedicated.server.nl
    ServerAlias my.dedicated.server.nl
    <Directory "/var/www/my.dedicated.server.nl">
    Options -Indexes
    </Directory>
    ScriptAlias /cgi-bin/ /var/www/my.dedicated.server.nl/cgi-bin/
    AddHandler cgi-script .cgi .pl
    <Directory "/var/www/my.dedicated.server.nl/cgi-bin/">
    allow from all
    Options +ExecCGI  -MultiViews +SymLinksIfOwnerMatch
    AllowOverride All
    Order deny,allow
    </Directory>
    </VirtualHost>
    
    
    #vanaf hier de virtual hosts neerzetten die op de server staan -----
    
    <VirtualHost 212.211.9.72:80>
    DocumentRoot "/var/www/fakelog.nl"
    ServerName www.fakelog.nl
    ServerAlias fakelog.nl
    <Directory "/var/www/fakelog.nl">
    Options Indexes
    </Directory>
    </VirtualHost>
     
  13. falko

    falko Super Moderator ISPConfig Developer

    Can you replace your current configuration with this one?

    Code:
    NameVirtualHost 212.211.9.72:80
    
    #--- hier de basis pagina van de server waar je op komt als er geen site is maar wel een domeinnaam -----
    
    <VirtualHost 212.211.9.72:80>
    DocumentRoot "/var/www/my.dedicated.server.nl"
    ServerName my.dedicated.server.nl
    ServerAlias my.dedicated.server.nl
    <Directory "/var/www/my.dedicated.server.nl">
    Options -Indexes
    </Directory>
    ScriptAlias /cgi-bin/ /var/www/my.dedicated.server.nl/cgi-bin/
    AddHandler cgi-script .cgi .pl
    <Directory "/var/www/my.dedicated.server.nl/cgi-bin/">
    allow from all
    Options +ExecCGI  -MultiViews +SymLinksIfOwnerMatch
    AllowOverride All
    Order deny,allow
    </Directory>
    </VirtualHost>
    
    
    #vanaf hier de virtual hosts neerzetten die op de server staan -----
    
    <VirtualHost 212.211.9.72:80>
    DocumentRoot "/var/www/fakelog.nl"
    ServerName www.fakelog.nl
    ServerAlias fakelog.nl
    <Directory "/var/www/fakelog.nl">
    Options Indexes
    </Directory>
    </VirtualHost>
     
  14. scherpenzeel

    scherpenzeel New Member

    I wil try that this evening. Thanks for the support. :)
     
  15. scherpenzeel

    scherpenzeel New Member

    I have replaced it with the above config. Still no change. I can log in into vqadmin but the same fault message over and over again.

    :confused: Whats next..
     
  16. scherpenzeel

    scherpenzeel New Member

    Today I tried some change on the same file as you advised. When restarting it gave me this message, also after restoring the config as it was:

    Code:
     /etc/init.d/apache2 restart
    Forcing reload of web server: Apache2[Fri Dec 08 14:27:55 2006] [warn] NameVirtualHost 212.220.9.72:80 has no VirtualHosts
    [Fri Dec 08 14:27:56 2006] [warn] NameVirtualHost 212.220.9.72:80 has no VirtualHosts
    ?

    I tried if it helped if I changed allow from all in deny from all.. as mentioned in the qmail FQ and on the http://www.inter7.com/vqadmin/install.txt site.

    Now when I changed it into deny from all I was not able to get in VQadmin anymore. So that did not help. Now I changed it back to allow from all and I can get in again but still get this message.......
    Code:
    vQadmin was unable to determine your username, which
    means your webserver is improperly configured to run
    with this CGI.  For security reasons, this script
    will not run without Apache htaccess lists.
     
  17. falko

    falko Super Moderator ISPConfig Developer

    Please change
    Code:
    <VirtualHost 212.211.9.72:80>
    DocumentRoot "/var/www/my.dedicated.server.nl"
    ServerName my.dedicated.server.nl
    ServerAlias my.dedicated.server.nl
    <Directory "/var/www/my.dedicated.server.nl">
    Options -Indexes
    </Directory>
    ScriptAlias /cgi-bin/ /var/www/my.dedicated.server.nl/cgi-bin/
    AddHandler cgi-script .cgi .pl
    <Directory "/var/www/my.dedicated.server.nl/cgi-bin/">
    allow from all
    Options +ExecCGI  -MultiViews +SymLinksIfOwnerMatch
    AllowOverride All
    Order deny,allow
    </Directory>
    </VirtualHost>
    to

    Code:
    <VirtualHost 212.211.9.72:80>
    DocumentRoot "/var/www/my.dedicated.server.nl"
    ServerName my.dedicated.server.nl
    ServerAlias my.dedicated.server.nl
    <Directory "/var/www/my.dedicated.server.nl">
    Options -Indexes
    </Directory>
    <Directory "/var/www/my.dedicated.server.nl/cgi-bin/">
    allow from all
    Options +ExecCGI  -MultiViews +SymLinksIfOwnerMatch
    AllowOverride All
    Order deny,allow
    </Directory>
    ScriptAlias /cgi-bin/ /var/www/my.dedicated.server.nl/cgi-bin/
    AddHandler cgi-script .cgi .pl
    </VirtualHost>
    What's the output of
    Code:
    ls -la /var/www/my.dedicated.server.nl/cgi-bin/
    ?
     
  18. scherpenzeel

    scherpenzeel New Member

    Code:
    ~# ls -la /var/www/my.dedicated.server.nl/cgi-bin/
    total 152
    drwxr-xr-x  3 hopla hopla   4096 2006-09-14 14:48 .
    drwxr-xr-x  6 hopla root     4096 2006-05-15 14:41 ..
    -rwxr-xr-x  1 hopla vchkpw 137816 2006-05-15 21:36 qmailadmin
    drwxr-xr-x  3 hopla vchkpw   4096 2006-09-14 20:50 vqadmin
    ? Which user is this? vchkpw ...?


    Before running the ls, I made a change in the .htacces and now I can log in, can even see the domainlist
    When I want to add a new domain it says:

    - Can not make domains directory

    And when I have a look at the e-mail accounts it says there is 0 users and no postmaster password. When I want to insert the password it says:
    -Create Domain: open .qmailadmin-limits failed

    When I have a look at the users it says:
    Users for greenprojects.nl Domain greenprojects.nl does not exist

    But I had a look at the mentioned path to where it should be and the dir is there. /home/vpopmail/domains/greenprojects.nl/postmaster/Maildir/

    ??

    I will also try the changes in the config as you meantioned above. Maybe this wil help as wel.
     
  19. scherpenzeel

    scherpenzeel New Member

    I tried your config as well, but that did not work. So now I still have acces but ca not modify or create anything.. as mentioned above. Maybe it has to do with server rights? or so.
     
  20. falko

    falko Super Moderator ISPConfig Developer

    Can you place the hello_world.pl test script in /var/www/my.dedicated.server.nl/cgi-bin/ and make it executable? Then try to access it in your browser. Does that work?
     

Share This Page