Problem getting bind to work properly

Discussion in 'Server Operation' started by dhjdhj, Mar 18, 2014.

  1. dhjdhj

    dhjdhj New Member

    I have been trying to get BIND to work on my Fedora 17 system to use as my primary DNS server. I was using dig with the IP address of that system to test and could not get it working.

    By fluke, I discovered that if I used localhost rather than the specific IP address of that machine (, then everything worked. So for example,

    dig @localhost



    dig @

    does not work.

    I'm hoping someone can tell me how to fix this.

    Thanks in advance.
  2. dhjdhj

    dhjdhj New Member

    ok --- figured this out --- in case anyone else runs into this issue, here's what you need to do

    1) Modify the config file (/etc/named.conf) and insert the explicit IP address of your server after the localhost address in the listen-on option. E.g.

    listen-on port 53 {;;

    2) Add your network to the allow-query option, E.g.

    allow-query {

    That last item allows any machine in your class-C subnet to query the DNS

Share This Page