Problem encountered on ""

Discussion in 'Server Operation' started by satimis, Mar 28, 2007.

  1. satimis

    satimis New Member

    Hi folks,


    # mysqladmin -u root password myrootsqlpassword
    Access denied for user \u2018root\u2019@'localhost\u2019 (using password: NO)
    # kill `cat /mysql-data-directory/`
    No complaint.

    What shall I do next? Repeat "mysqladmin -u root password myrootsqlpassword"?

    10 Postfix With SMTP-AUTH And TLS

    [root@server ssl]# openssl genrsa -des3 -rand /etc/hosts -out smtpd.key 1024
    188 semi-random bytes loaded
    Generating RSA private key, 1024 bit long modulus
    e is 65537 (0x10001)
    Enter pass phrase for smtpd.key:
    What shall I enter here? TIA

    # openssl req -new -key smtpd.key -out smtpd.csr
    It also requests "Enter pass phrase for smtpd.key"

    What shall I enter as well ?

  2. satimis

    satimis New Member

    Hi folks,

    On my previous posting
    I made a mistake leaving out "--" before "password"

    Retried as follows;

    [root@server ~]# mysqladmin -u root --password mypassword
    Enter password: 
    Typing either "mypassword" or "YES" prompted;
    mysqladmin: connect to server at 'localhost' failed
    error: 'Access denied for user 'root'@'localhost' (using password: YES)'
    Also tried as "su -"

    Still failed

  3. falko

    falko Super Moderator ISPConfig Developer

    I suggest you reinstall the system.

    Just specify a password. It doesn't matter which one.
  4. satimis

    satimis New Member

    I have the same feeling that there is something wrong on this CentOS 4.4 amd64 box. I'll erase the complete OS later.

    No use, I tried half day without a breakthrough including groupremoving mysql and reinstalling them as per your howto. Still encountered the same problem.

  5. satimis

    satimis New Member

    Another round

    Hi folks,

    Erased the complete HD and started another round according to;

    All steps went through w/o complaint.

    Coming to;

    # mysqladmin -u root password myrootsqlpassword
    went through w/o complaint

    # mysqladmin -h -u root password myrootsqlpassword (assuming it is ONE line)
    mysqladmin: connect to server at '' failed
    error: 'Lost connection to MySQL server during query'
    # cat /etc/hosts
    Code:            localhost.localdomain  localhost  server1
    Pls advise which file I have to check? TIA

    I found following thread;

    To my understanding I suppose skipping to run "mysqladmin -h -u root password myrootsqlpassword"

    on /etc/sysconfig/network-scripts/ifcfg-eth0


    on /etc/sysconfig/network-scripts/ifcfg-eth0:0

    Is there any specific meaning on selecting the above IPADDR? On my router here "" is reserved for Server. If changing "" to "" would this change affect the test?

    Last edited: Mar 30, 2007
  6. falko

    falko Super Moderator ISPConfig Developer

    No, there was nothing wrong with the system, but you did something wrong, and telling you how to fix it would have taken longer than just reinstalling the system. :p

    Yes, skip this step for now. Later on you can use phpMyAdmin to check out which hostname is saved in the mysql.user table in the field "Host" (will be different from because otherwise your command would have succeeded).

    You don't need to create a virtual IP address. This is just an example for people that need it.
  7. satimis

    satimis New Member

    Fail to start proftpd

    Hi folks,

    Section 12 ProFTPd

    # /etc/init.d/proftpd start
    Starting proftpd: - getaddrinfo '' error: Name or service not known
    - warning: unable to determine IP address of ''
    - error: no valid servers configured
    - Fatal: error processing configuration file '/etc/proftpd.conf'
    Pls advise how to fix it. TIA


    I fixed my problem by putting " host" to replace "localhost.localdomain localhost" on /etc/hosts. Thereafter proftpd started.

    I completed the rest part according to the tutorial without problem. Tks falko for your nice howto-tutorial.

    Hi folks,

    Are there documents explaining the commands on the howto-tutorial mentioned instead of googling on each command or going through the respective site of each package? Man is too brief on their explanation.

    Is there a ISPConfig installation/config howto, other than follow;



    A further thought - ispconfig vs ravencore

    What will be your opinion?

    Last edited: Mar 31, 2007
  8. falko

    falko Super Moderator ISPConfig Developer

Share This Page