problem during build the perfect server ubuntu ispconfig3

Discussion in 'Installation/Configuration' started by ianth, Oct 6, 2010.

  1. ianth

    ianth New Member

    when I got the

    aptitude install postfix postfix-mysql postfix-doc mysql-client mysql-server courier-authdaemon courier-authlib-mysql courier-pop courier-pop-ssl courier-imap courier-imap-ssl libsasl2-2 libsasl2-modules libsasl2-modules-sql sasl2-bin libpam-mysql openssl getmail4 rkhunter binutils maildrop

    You will be asked the following questions:

    New password for the MySQL "root" user: <-- yourrootsqlpassword
    Repeat password for the MySQL "root" user: <-- yourrootsqlpassword
    Create directories for web-based administration? <-- No
    General type of mail configuration: <-- Internet Site
    System mail name: <-- server1.example.com
    SSL certificate required <-- Ok

    on page 4

    I didn't get any questions at all and this is the difference I got after doing it a day or 2 ago successfully

    The following actions will resolve these dependencies:

    [email protected]:~# aptitude install postfix postfix-mysql postfix-doc mysql-client mysql-server courier-authdaemon courier-authlib-mysql courier-pop courier-pop-ssl courier-imap courier-imap-ssl libsasl2-2 libsasl2-modules libsasl2-modules-sql sasl2-bin libpam-mysql openssl getmail4 rkhunter binutils maildrop
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Reading extended state information
    Initializing package states... Done
    No candidate version found for postfix
    No candidate version found for postfix-mysql
    Couldn't find any package whose name or description matched "postfix-doc"
    No candidate version found for libsasl2-modules-sql
    No candidate version found for sasl2-bin
    No candidate version found for binutils
    No candidate version found for postfix
    No candidate version found for postfix-mysql
    Couldn't find any package whose name or description matched "postfix-doc"
    No candidate version found for libsasl2-modules-sql
    No candidate version found for sasl2-bin
    No candidate version found for binutils
    The following packages are BROKEN:
    citadel-mta courier-authlib mysql-client-5.1 mysql-server-5.1 rkhunter
    The following NEW packages will be installed:
    citadel-common{a} courier-authdaemon courier-authlib-mysql
    courier-authlib-userdb{a} courier-base{a} courier-imap courier-imap-ssl
    courier-pop{a} courier-pop-ssl courier-ssl{a} expect-tcl8.3{a} libfam0{a}
    maildrop mysql-client mysql-client-core-5.1{a} mysql-server
    mysql-server-core-5.1{a} tcl8.3{a} unhide{a}
    0 packages upgraded, 24 newly installed, 0 to remove and 0 not upgraded.
    Need to get 24.0MB of archives. After unpacking 58.4MB will be used.
    The following packages have unmet dependencies:
    mysql-server-5.1: Depends: libdbi-perl which is a virtual package.
    citadel-mta: Depends: citadel-server (>= 7.50) but it is not installable
    mysql-client-5.1: Depends: libdbi-perl which is a virtual package.
    Depends: libdbd-mysql-perl (>= 1.2202) which is a virtual package.
    courier-authlib: Depends: libltdl7 (>= 2.2.6a) which is a virtual package.
    rkhunter: Depends: binutils which is a virtual package.
    The following actions will resolve these dependencies:

    Keep the following packages at their current version:
    citadel-mta [Not Installed]
    courier-authdaemon [Not Installed]
    courier-authlib [Not Installed]
    courier-authlib-mysql [Not Installed]
    courier-authlib-userdb [Not Installed]
    courier-base [Not Installed]
    courier-imap [Not Installed]
    courier-imap-ssl [Not Installed]
    courier-pop [Not Installed]
    courier-pop-ssl [Not Installed]
    courier-ssl [Not Installed]
    maildrop [Not Installed]
    mysql-client [Not Installed]
    mysql-client-5.1 [Not Installed]
    mysql-server [Not Installed]
    mysql-server-5.1 [Not Installed]
    rkhunter [Not Installed]

    Score is -99249

    Accept this solution? [Y/n/q/?]

    how do I fix this ?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Your package database is outdated. Run:

    apt-get update

    to fix this and then try again.
     
  3. ianth

    ianth New Member

    looks like its working thanks till
     
  4. ianth

    ianth New Member

    I got an error during ispconfig how can I remove it and start again?
     

Share This Page