Problem Defining Quota During PureFTPD Installation

Discussion in 'Server Operation' started by DirtyTodd, Jul 17, 2017.

  1. DirtyTodd

    DirtyTodd New Member HowtoForge Supporter

    Hi Folks,

    I am following
    The Perfect Server - Debian 8.4 Jessie (Apache2, BIND, Dovecot, ISPConfig 3.1)
    During step 14

    when I run
    I get my fstab as follows:
    Code:
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    /dev/sda1       /       ext4    errors=remount-ro,relatime,discard      0      $
    /dev/sda2       /home   ext4    defaults,relatime,discard       1       2
    /dev/sda3       swap    swap    defaults        0       0
    proc            /proc   proc    defaults                0       0
    sysfs           /sys    sysfs   defaults                0       0
    tmpfs           /dev/shm        tmpfs   defaults        0       0
    devpts          /dev/pts        devpts  defaults        0       0
    I edited it like below
    Code:
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    /dev/sda1       /       ext4    errors=remount-ro,usrjquota=quota.user,grpjquot$
    /dev/sda2       /home   ext4    usrjquota=quota.user,grpjquota=quota.group,jqf$
    /dev/sda3       swap    swap    defaults        0       0
    proc            /proc   proc    defaults                0       0
    sysfs           /sys    sysfs   defaults                0       0
    tmpfs           /dev/shm        tmpfs   defaults        0       0
    devpts          /dev/pts        devpts  defaults        0       0
    
    Then I run
    Code:
    mount -o remount /
    and then when I run
    I get error
    Code:
    quotacheck: Cannot stat() mounted device /dev/root: No such file or directory
    quotacheck: Cannot find filesystem to check or filesystem not mounted with quota option.
    and when I run
    I get error as below
    Code:
    quotaon: Cannot stat() mounted device /dev/root: No such file or directory
    Can any one help me out.
     
    Last edited: Jul 18, 2017
  2. DirtyTodd

    DirtyTodd New Member HowtoForge Supporter

    Finally Managed to enable Quota but I get error
    Code:
    quotacheck: Cannot stat() mounted device /dev/root: No such file or directory
    quotacheck: Quota for users is enabled on mountpoint /home so quotacheck might damage the file.
    Please turn quotas off or use -f to force checking.
    
    so I used
    quotacheck -avugm -f
    and the result was
    Code:
    quotacheck: Cannot stat() mounted device /dev/root: No such file or directory
    quotacheck: Scanning /dev/sda2 [/home] done
    quotacheck: Checked 2 directories and 4 files
    and when I used
    quotaon -avug
    result was
    Code:
    quotaon: Cannot stat() mounted device /dev/root: No such file or directory
    quotaon: using /home/quota.group on /dev/sda2 [/home]: Device or resource busy
    quotaon: using /home/quota.user on /dev/sda2 [/home]: Device or resource busy
    on running
    quotaon -avug -f
    result was
    Code:
    quotaon: Cannot stat() mounted device /dev/root: No such file or directory
    /dev/sda2 [/home]: group quotas turned off
    /dev/sda2 [/home]: user quotas turned off
    
    on running quotaon-avug again
    result was
    Code:
    quotaon: Cannot stat() mounted device /dev/root: No such file or directory
    /dev/sda2 [/home]: group quotas turned on
    /dev/sda2 [/home]: user quotas turned on
    Now just a simple question where will all the files will be saved for resellers and clients
    in /
    or in
    /home

    I will adjust the size of partition accordingly
    current is
    / is 400GB
    and
    /Home is 99GB
    and /Swap is 1GB

    Help will be appriciated
     

Share This Page