Problem configuring postfix as backup mx

Discussion in 'Server Operation' started by iNiko, Feb 11, 2009.

  1. iNiko

    iNiko New Member

    Hi all,
    i need to configure a secondary mx using posfix.. to do this i've followed this how to.

    When i stop postfix on the primary mx, seems that the email are received by backup mx but when i restart postfix on the primary emails are not delivered to it.. and the users cannot receive nothing.

    Some logs on backup mx:
    Code:
    Feb 11 22:17:19 neptune postfix/qmgr[19273]: 6D41C1200149: from=<[email protected]>, size=14816, nrcpt=1 (queue active)
    Feb 11 22:17:49 neptune postfix/smtp[26666]: 6D41C1200149: to=<[email protected]>, relay=none, delay=102080, delays=102050/0.03/30/0, dsn=4.4.1, status=deferred (connect to primarymx.domain.com[primary_MX_IP]: Connection timed out)
    
    Backup MX main.cf:
    Code:
    
    myhostname = neptune.domain.com
    mydomain = domain.com
    
    smtpd_recipient_restrictions = permit_sasl_authenticated, permit_mynetworks, reject_unauth_destination, permit_mx_backup
    relay_domains = $mydestination domain.com testdomain.com
    
    relay_recipient_maps =
    maximal_queue_lifetime = 60d
    transport_maps = hash:/etc/postfix/transport
    
    /etc/postfix/transport :

    Code:
    domain.com	smtp:primarymx.domain.com
    testdomain		smtp:primarymx.testdomain.com
    
    Obviusly on primary mx maillog i've no logs about the emails received by backup mx..

    What's my mistake? How can i solve ?

    Thank you so much for help!
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Can you connect from the backup MX to the primary MX like this?
    Code:
    telnet primarymx.domain.com 25
     

Share This Page