Problem: CentOS Turning Into A Server

Discussion in 'Server Operation' started by destinedjagold, Aug 29, 2012.

  1. destinedjagold

    destinedjagold New Member

    Hello and good day everyone.
    I am kinda new to Linux/CentOS-turn-into-a-server thing, and I have been trying for almost two weeks now to try and figure this out by myself, and I have not successfully reached the goal.

    Anyway, I have recently followed this tutorial...
    Well, not exactly, no.
    I did not want to freshly reformat the server PC though.
    On the said tutorial, I began to follow it on the part where the CentOS has been installed, and the part where I am asked to run the command "system-config-firewall-tui"...

    My problem is that I get a "502 Bad Gateway" message when I try to access https://192.168.1.16:8080/ ...

    I don't really know what information I need to provide though.
    I simply followed the said tutorial.

    And while I'm at it, is there a good tutorial for me to type a name to access the server instead of typing the server's I.P. address on the web browser?
    I've tried searching for it as well, but I ended up creating chaos on our server. =/


    Hope you pipz can enlighten me on this problem o'mine.
    Thankies~
     
  2. orfi

    orfi New Member

    502 gateway ?

    if you have acess to CLI just check the network side of the server

    something like :
    ifconfig eth0
    route -n
    arp -n ( check the MAC of the gateway )
    ping " ip of the gateway"
     
  3. destinedjagold

    destinedjagold New Member

    If what you mean by CLI is command-line interface, then yes, I have access to it. It's the only way I am able to reach and do some things with the server.

    Anyway, I tried doing what you suggested, and here are the results.

    ifconfig eth0
    Code:
    eth0      Link encap:Ethernet  HWaddr 00:90:99:33:98:B1
              inet addr:192.168.1.16  Bcast:192.168.1.255  Mask:255.255.255.0
              inet6 addr: fe80::290:99ff:fe33:98b1/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:5950 errors:0 dropped:0 overruns:0 frame:0
              TX packets:325 errors:0 dropped:0 overruns:0 carrier:0
              collisions:2 txqueuelen:1000
              RX bytes:682794 (666.7 KiB)  TX bytes:42115 (41.1 KiB)
              Interrupt:18 Base address:0xa000
    
    route -n
    Code:
    Kernel IP routing table
    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
    192.168.1.0     0.0.0.0         255.255.255.0   U     1      0        0 eth0
    0.0.0.0         192.168.1.1     0.0.0.0         UG    0      0        0 eth0
    
    arp -n
    Code:
    Address                  HWtype  HWaddress           Flags Mask            Iface
    192.168.1.9              ether   00:19:66:cb:f7:97   C                     eth0
    
    And I can ping the gateway.

    Any help would be appreciated.
    Thank you~
     
  4. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Make sure that PHP-FPM is started. If it doesn't start, check the logs in /var/log/ for errors. Also, make sure that SELinux is disabled.
     

Share This Page