Problem before activate Redirect Type R,L and Rewrite HTTP to HTTPS

Discussion in 'ISPConfig 3 Priority Support' started by Galopete, Nov 1, 2018.

  1. Galopete

    Galopete New Member HowtoForge Supporter

    Hello
    I have a server Ubuntu 14.04 running ISP Config. I have three sites including the acces to ISP Config (www.mysite.com:8080).

    I'm trying to activate SSL with let's encrypt in one of these sites in my server, but before change Redirect type to R,L and mark the Option Rewrite HTTP to HTTPS in the "Redirect" options windows in ISP Config, now i cannot access to ISP Config control panel, and any other site in my server too...

    How can i undo the changes made?

    Thanks,
    Abraham
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Which ispconfig version do you use?

    Try to remove the symlink of the affected site in /etc/nginx/sites-enabled/ and restart bginx.
     
  3. Galopete

    Galopete New Member HowtoForge Supporter

    Hello Till
    I'm using the last version of ISP Config, with Apache2.
    While i'm waiting for help here, i'm becoming crazy with this problem... but finally i have seen that the symlinks ispserver.crt and ispserver.key in the directory /usr/local/ispconfig/interface/ssl was incorrect, i erased it and retype it with correct data (pointing to the correct directory).
    Really the reason to i cannot access ispconfig panel and other sites was that the apache2 web server was down due to incorrects symlinks (explained upside), when i try to restart apache2 it return me the this error: "SSLCertificateFile: file '/usr/local/ispconfig/interface/ssl/ispserver.crt' does not exist or is empty" (symlinks wrong), then i correct the symlinks, and Apache restarts fine. Now all is working fine.
    Many thanks for your quick response, Till.
    BR, Abraham.
     

Share This Page