Problem after upgrade...

Discussion in 'Installation/Configuration' started by dejan.b, Jun 18, 2012.

  1. dejan.b

    dejan.b New Member

    Hello!

    Recently i upgraded from Debian 5 to 6 and everything worked ok.
    Few days ago, i upgraded ISPconfig panel to version 3.0.4.5 on the same server and now i can't start dovecot.

    It says: Restarting IMAP/POP3 mail server: dovecotError: Error in configuration file /etc/dovecot/dovecot.conf line 106: Unknown setting: mail_uid

    Can't find any info on net...

    Regards!
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Which dovecot verion is currently running on your server?
     
  3. dejan.b

    dejan.b New Member

    Hello!

    1:1.0.15-2.3+lenny1
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats the version from lenny and not squeeze and the ispconfig updater assumes that you run the software versions that belong to the distribution version in /etc/debian_version, so it might be that the dovecot.conf uses a syntax now which is too new for the installed dovecot version.

    There are two options, either update dovecot to the version that belongs to debian 6 or use the dovecot conf that was used before you updated ispconfig. The ispconfig updater makes a backup of the /etc/ directory were you can find the old config file. The backups are stored in /var/backup
     
  5. dejan.b

    dejan.b New Member

    Thanks Till!

    I reinstalled dovecot and now it works like it should...
     

Share This Page