problem after upgrade to ispconfig 2.2.0

Discussion in 'Installation/Configuration' started by adrenalinic, Mar 1, 2006.

  1. adrenalinic

    adrenalinic HowtoForge Supporter

    HI.
    I have upgrade ispconfig to latest version, but when join to control pannel as administrator and click on Management->Server, all Server sub menu not is diponible and i cannot see setting of server, service and status!!!!!

    my browser error:
    Url not found


    Url not found www.207.210.96.14.

    The system, in management-> service section, search for domain www.207.210.96.14 and not only ip 207.210.96.14

    HELP HELP!
     
  2. drsintoma

    drsintoma New Member

    Have a look at this.

    Detailed Changelog
    ------------------
    - Support for 64Bit Linux:
    .....
    .....
    - The server url is now set dynamically in config.inc.php.
     
  3. adrenalinic

    adrenalinic HowtoForge Supporter

    yes i have see already my config.inc.php

    and...:

    $go_info["server"]["server_url"] = "https://207.210.96.14:81";

    but this is correct?! is my ip..

    what I would have to change in server variable url?!
    Thanks josef
     
  4. drsintoma

    drsintoma New Member

    I didn't upgrade yet. But, there is no other variable $go_info["server"]["host"] or something?
     
  5. adrenalinic

    adrenalinic HowtoForge Supporter

    i dont see....

    this is my files....
    have replaced sensitive data with "XXXXXX"
    /**********************************************
    * System Settings
    **********************************************/

    $go_info["server"]["dir_trenner"] = "/";
    $go_info["server"]["server_root"] = "/home/admispconfig/ispconfig";
    if(isset($_SERVER['SERVER_NAME']) && isset($_SERVER['SERVER_PORT'])){
    $go_info["server"]["server_url"] = 'https://'.$_SERVER['SERVER_NAME'].':'.$_SERVER['SERVER_PORT'];
    } else {
    $go_info["server"]["server_url"] = "https://xxx.xxx.xxx.:81";
    }
     
    Last edited: Mar 1, 2006
  6. till

    till Super Moderator

    You can try to replace these lines:

    Code:
    if(isset($_SERVER['SERVER_NAME']) && isset($_SERVER['SERVER_PORT'])){
    $go_info["server"]["server_url"] = 'https://'.$_SERVER['SERVER_NAME'].':'.$_SERVER['SERVER_PORT'];
    } else {
    $go_info["server"]["server_url"] = "https://207.210.96.14:81";
    }
    with:

    Code:
    $go_info["server"]["server_url"] = "https://207.210.96.14:81";
    By the way, please do not post the same question in several forums.
     
  7. adrenalinic

    adrenalinic HowtoForge Supporter

    yes.
    scumsy for my multply post! scusmy...

    the modifie to code works!!
    very very very thanks!
     

Share This Page