Problem after update debian 9 to 10

Discussion in 'ISPConfig 3 Priority Support' started by muekno, Jan 31, 2021.

  1. muekno

    muekno Member HowtoForge Supporter

    did an update for 2 of my ispconfig servers mail and sql in my production multiserver enviorement
    did this weeks before with other servers in my test and in my production enviorement (amd64 servers means 64bit) without any problems
    Now an these 2 servers (i686 server means 32bit) I did the same, latest update, change stretch to buster in sources.list, update, upgrade, distupgrade, reboot, --purge autoremove. No problems on first view. My mail ist just forwarded to a backend mail system, that works. My customers mail are mostly accessed via IMAP some times via RoudCube.
    Now I noticed I can not login in to my test mailbox in RoudCube and can not connect to the same mailbox via IMAP with the MAC mail app.
    so I'm gone to ISPconfig to reset my mailbox password, may be I do not remember coorect (do not use it frequently) the update never ends the red circeld 1 on top does not disapere. So I'm gone to monitor that tolds me Error on mail server postfix offline, checking postfix on the console, postfix ist running.
    All servers are on latest ISPconfig 3.2.2 since it came out
    Next I did a fore update on the updates on the sql server (databases seams to work as the websites work) and got
    I know its sunday but its urgend. otherwise I habe to revert to snaphshot from yesterday morning before, loos mails coming in since then.
    Thanks for any hint help
    Rainer
     
  2. muekno

    muekno Member HowtoForge Supporter

    One problem ist solved "the force update" mbstring-php was missing
    but still the warning smtp offline and the red 1 is not disapering
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Go through the Debian 10 perfect server guide and run each command to install missing packages. Afterward, run an ispconfig update with reconfigure services = yes.

    Just be careful to not install acme.sh when your server is using certbot already, skip this step from perfect server.
     
  4. muekno

    muekno Member HowtoForge Supporter

    While running force upgrade of ISPconfig I got the error mentioned here https://www.howtoforge.com/community/threads/i-performed-an-ispconfig_update-sh-as-a-test.85001/
    biut I am shure I did not downgrade as all server were at 3.2.2 since weeks. So I did an update system was up to date, so I tried to do a force update on ISPconfig and got new error
    I also tried to switch on debug on the mail server but i seams not to take this the red 1 stays as a red 3 nown
    #6 {main}
    thrown in /tmp/ispconfig3_install/install/lib/mysql.lib.php on line 448
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Go through the perfect server guide and install missing packages as I mentioned above, the PHP that you have installed on the server lacks modules. You should also check that the PHP version is the right one for the new os version with:

    php --version
     
  6. muekno

    muekno Member HowtoForge Supporter

    Hello Till, thank you
    I ran through the tutorial only some php 7.3 module were missing.
    The red number disappears while going through the tutorial
    I can login to my mailbox via roudcube again so I hope everything works fine now
    Good evening and stay healthy in these crazy times
     
  7. muekno

    muekno Member HowtoForge Supporter

    Everything works fine now but there is still a little problem.
    The updated servers show incorrect information in monitor
    "Servername (Debian unknown) ISPconfig 3.1.13p1"
    they are definitly on debian 10
    And they had ISPconfig 3.2.2 before the update, and got a force update to ISPconfig 3.2.2 after the update. After notifying problem I did a force update again, no change.
    What to do?
    Thanks Rainer
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Check that you have not commented out any of the ispconfig root cronjobs on the affected server. The version number does not get updated immediately after an install, it takes a few minutes.

    If the cronjobs are all running, in this case, it's the cron cronjob, not the server.sh cronjob. then you can use debug mode to find out why the slave can not connect anymore to the master. Another possible reason can be wrong MySQL permissions, have you reconfigured permissions in master database?
     
  9. muekno

    muekno Member HowtoForge Supporter

    I know there is some delay till the monitor is updatet, but from yesterday afternoon to this morning should be enough :)
    I did not touch any cronjob and the problem shows on any updated server (3)
    I have reconfured permissions in master.
    But even the master is one of the effected server.
    debug shows
    what does that mean?
    Thanks
    Rainer
     
  10. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

  11. till

    till Super Moderator Staff Member ISPConfig Developer

    Try to run a optimize & repair on all database tables of the dbispconfig database on the master server e.g. with phpmyadmin to ensure that no database table is in a crashed state.

    Is this from a mail server? Might be that the rspamd plugin is enabled on a non-mail server.
     
  12. muekno

    muekno Member HowtoForge Supporter

    Postfix is installed but this server is only master and dns, in the system config only web and dns are set to yes
    Rainer
     
  13. muekno

    muekno Member HowtoForge Supporter

    Did run a optimize & repair on all database tables of the dbispconfig
    repair all tables OK
    optimize all tables OK
    Result from /usr/local/ispconfig/server/server.sh did not change
    Rainer
     
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok, this explains the error. Go to /usr/local/ispconfig/server/plugins-enabled/ folder and delete the symlink for the rspamd plugin.
     
  15. muekno

    muekno Member HowtoForge Supporter

    OK these errors are gone, next server it is just mail and web
     
  16. muekno

    muekno Member HowtoForge Supporter

    after removing the rspamd I removed the comment in crontab of master
    the faulty message in monitor still remains, about one hour now

    Rainer
     
  17. till

    till Super Moderator Staff Member ISPConfig Developer

    Please run the command as root:

    crontab -l

    and post the result.
     
  18. muekno

    muekno Member HowtoForge Supporter

    I will be out the afternoon
     
  19. till

    till Super Moderator Staff Member ISPConfig Developer

    That's ok. Any errors when you run:

    /usr/local/ispconfig/server/cron.sh

    as root user?
     
  20. muekno

    muekno Member HowtoForge Supporter

Share This Page