Problem after custom php.ini

Discussion in 'Installation/Configuration' started by alme, Sep 5, 2011.

  1. alme

    alme New Member

    Hello
    Following your guides on how to make changes into php.ini i went to options and place my own php.ini settings. PHp is inder Fast-cgi.
    I'm using ispconfig3 under centos 6. PHP 5.3.2 .After making my default php.ini and placing it in options whe I go to my site I get:
    Database Error: Unable to connect to the database:The MySQL adapter "mysql" is not available.
    Is there a way how to fix this or how to go back to previous settings ?
    I tried to remove everything in the option and saving under empty box with the hope that this will overwrite the changes but no luck.
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Have you tried to restart Apache?
     
  3. alme

    alme New Member

    Yes I tried that many times.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    check with the phpinfo() function which php.ini file gets loaded for that website.
     
  5. alme

    alme New Member

    Hello
    Thank you for your replies. Looks like the php.ini that loads is the one that is generated from ispconfig.
    Is there a way to manually remove it or the records I set in ispconfig so it rolls back to the default php.ini?
     
  6. pititis

    pititis Member

    Just clear the php.ini input box.
     
  7. alme

    alme New Member

    Tried that no result.Same problem.
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    And you are really sure that the custom php.ini file has not changed? Check the file modification date, the file gets updated with the values from the main php.ini file on every change that you do in the field.
     

Share This Page