Problem adding SPF records

Discussion in 'Installation/Configuration' started by conductive, Dec 9, 2016.

  1. conductive

    conductive Member

    I can not send email to any addresses @ Bellsouth. I have read previous posts on this subject but I still can not get this a the SPF records working. When I go to the ispconfig3 DNS Zone go to add a TXT record I get the following:

    Hostname
    Text
    TTL

    Exactly what should I add on these lines to make it so these records will work and/or can be properly read.
    Thanks for your help.
     
  2. soho

    soho Member

    Hostname=your_domain.com.
    Text= v=spf1 mx a ~all
    TTL=3600
     
    conductive likes this.
  3. conductive

    conductive Member

    Simply entering the TXT record did not fix my problem. Due to my configuration I had to enter this information into the Host Records at my domain name registrar. Now I have valid SPF records unfortunately it has not completely solved my problem since my server IP address appears to be on Blacklist. I called my service provider to see if they could straighten out this IP address.

    Thanks for the help..
     
  4. soho

    soho Member

    You probably have an extra layer of settings provided by your registrar. Usually in the registrar, just point the name servers (in your case, the ISPConfig server) and all requests will be forwarded to these name servers.

    If the IP address provided to you and used on the ISPConfig (mail server) is blacklisted, you will have trouble sending mail, but not all domains, as some do not query all RBLs. For example, the IP address of my mail server was listed on sorbs.net (I was able to remove it yesterday) as of 15/11, but I was sending emails to multiple domains, including gmail and outlook.

    Regarding SPF, if you are using ISPConfig 3.1.x, when you add a zone the SPF record will be created automatically, as well as when you include an email domain, you can generate and insert a DKIM record with its respective key in the DNS zone.
     
    conductive likes this.

Share This Page