Problem accessing Web-FTP in ISPConfig

Discussion in 'Installation/Configuration' started by ctroyp, Nov 13, 2005.

  1. ctroyp

    ctroyp New Member HowtoForge Supporter

    When I login to one of my websites via Web-FTP in the ISPConfig cp, I get:
    Code:
    Warning: main(weblibmodule.inc.php) [function.main]: failed to open stream: No such file or directory in /home/admispconfig/ispconfig/lib/session.inc.php on line 238
    
    Warning: main() [function.include]: Failed opening 'weblibmodule.inc.php' for inclusion (include_path='.:/root/ispconfig/php/lib/php') in /home/admispconfig/ispconfig/lib/session.inc.php on line 238
    
    Warning: go_api::uses(ispconfig_isp_web.lib.php) [function.uses]: failed to open stream: No such file or directory in /home/admispconfig/ispconfig/lib/session.inc.php on line 126
    
    Warning: go_api::uses() [function.include]: Failed opening 'ispconfig_isp_web.lib.php' for inclusion (include_path='.:/root/ispconfig/php/lib/php') in /home/admispconfig/ispconfig/lib/session.inc.php on line 126
    
    Fatal error: Class 'isp_web' not found in /home/admispconfig/ispconfig/lib/session.inc.php on line 127
    ...in the right-hand pane. This only happens with one of my sites.

    Any ideas?
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    You get this only in one of your sites, the other sites are working with Web-FTP? Can you connect with a normal FTP client to the site where the webFTP fails?
     
  3. ctroyp

    ctroyp New Member HowtoForge Supporter

    Correct. The other sites work fine. Plus, I can access them from a browser as well.
     
  4. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    And have you tried my second question:

     
  5. ctroyp

    ctroyp New Member HowtoForge Supporter

    Correct, works fine with a normal FTP client.
     
  6. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Hmmm, really strange behaviour :confused:
     
  7. ctroyp

    ctroyp New Member HowtoForge Supporter

    I know. Everything within FTP seems functional except the right-hand pane when viewing it in the Web-FTP page of the ISPConfig cp.

    Actually, I just thought of another error message when using PHPMyAdmin. When I login to PHPMyAdmin, I get a message at the bottom:
    Code:
    The mbstring PHP extension was not found and you seem to be using a multibyte charset. Without the mbstring extension phpMyAdmin is unable to split strings correctly and it may result in unexpected results.
    Do you think this would have anything to do with it?
     
  8. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    No, the mbstring extension is not used within ISPConfig.
     
  9. ctroyp

    ctroyp New Member HowtoForge Supporter

    Ok, I thought I would mention it just in case.
     
  10. joostvdl

    joostvdl Member

    Today I updated to 2.1.1 and I have the same problem here.

    Some sites are working, some not. I check the ownership of the directories but I couldn't find anything strange here....
     
  11. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    I've checked this and cant find the error. The problem is that there is no file weblibmodule.inc.php at all and the string "weblibmodule.inc.php" is not in the sources :confused:
     
  12. ctroyp

    ctroyp New Member HowtoForge Supporter

    Hmmm, I wonder where the filename is referenced from? What file is trying to access the "weblibmodule.inc.php" file and why is it trying to assess it:confused:
     

Share This Page