Proble when upgrading Mysql server to 5.7 and ispconfig3

Discussion in 'Installation/Configuration' started by pedrule, Aug 26, 2016.

  1. pedrule

    pedrule New Member


    I tried to install the new release of mysql 5.7 but I cannot open ispconfig anymore.

    here the home page I got from ispconfig. Do you know if there is an solution to this ? is it a compatibility issue ?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, you can not use ISPConfig 3.0.5.x with MySQL 5.7 as MySQL 5.7 is not fully compatible to older MySQL versions. Either you downgrade MySQL or you upgrade ISPConfig to the 3.1 pre-release.
  3. pedrule

    pedrule New Member

    Thanks to your reply, without you I was unable to find the info on the web.
    If I choose the 3.1 release, I have to follow the same steps as previous release to make a perfect install ?
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    You can find the perfect server tutorials for ISPConfig 3.1 here at howtoforge.
  5. pedrule

    pedrule New Member

    Thaks for reply Till,
    I've got an other issue since I try to update nginx to the last stable version.
    since I've done it, I've got the message

    I can't find what I missed.
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Check the Nginx log file. Btw, I won't update individual system to the latest versions, better stay with versions that ship with the OS and update to a newer OS version when it gets released. This ensures that you get a stable system.
  7. pedrule

    pedrule New Member

    problem for me : the last shipped version of nginx is 1.6.3 and this version don't support http2, so I would like to embed in my perfect install mysql 5.7 (ok), php 7(ok), ispconfig 3.1(ok) and nginx http2 ( for reverse proxy configuration ) (not ok ) .

    I there some solutions ?

    for info, my error log in nginx :

    Attached Files:

Share This Page