Discussion in 'General' started by teves, Dec 6, 2006.

  1. teves

    teves Member


    today I uploaded a site via ftp onto my new ispconfig-managed webserver for the first time. Then I noticed the site could not be viewed. I quickly found it was a rights problem and was able to fix it. But now I am a bit unsure. Could someone please tell me what are the proper privileges I need to set for the different filetypes (or where can I read about it) ? E.g. what must be set for .html, .php, .pl, picture files,.... etc.

    Another problem with this new page is, that it is found under http://www.pagename.tld but not under http://pagename.tld. With the second notation I get the ISPConfig's error page saying that this is a shared IP-address. I wonder why, because all of my other pages (these are online pages with yet no content) work both ways. Any hints?

    Thank you,
    regards, Tom
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Which permissions and owner did the files had after you uploaded it? Did you modify anithing in the ISPConfig sources regarding the permissions and file owners?

    you must add pagename.tld as co-domain with empty host field to the website www.pagename.tld
  3. teves

    teves Member

    The co-domain hint worked, but I'm still wondering about two things:
    1. Why didn't that problem occur with the other pages?
    2. I had a domain limit of 2 set for this web. Though I had only registered the domainname.tld I got the error "domain limit reached" when I tried to register the co-domain. When I set the limit to 3 it worked. How can that be?

    The owner/group settings were correct, I think (web13_admin and web13).
    The permissions were rw for admins and r for the group for all files/directories, as far as I remember.

    thank you!
    regards, Tom
  4. falko

    falko Super Moderator ISPConfig Developer

    Let's assume you create a web site ISPConfig automatically creates the Co-Domain as well, so that makes two domains already. Therefore you need to set the limit to three at least if you want to add another Co-Domain.

Share This Page